Results 1 to 7 of 7

Thread: NDI Adobe plugin and After effect with no alpha

  1. #1
    Thomas TV2
    Join Date
    May 2011
    Location
    copenhagen
    Posts
    92

    NDI Adobe plugin and After effect with no alpha

    Hi

    The Ndi plugin works with alpha from Adobe Premiere, but I cant seam to get it working from After effect. Only with a background color.
    Is it still not possible? I read in an old post that After effect do not support it. Only Premiere.

    Thomas

    TC 8000 AE2
    Tricaster 8000 AE2

  2. #2
    There are two plug-ins.

    'NewTek_NDI_Transmit.prm' and 'NewTek_NDI_AfterEffects.aex' (on Windows)

    The 'prm' plug-in works in Premiere and After Effects, because of how After Effects handles alpha channel it doesn't get passed using the 'prm' plug-in, but Premiere does.

    The 'aex' plug-in works on in After Effects only and supports alpha. What I just noticed is that it appears that an Adobe update appears to make the 'prm' plug-in take priority over the 'aex' one. If I remove 'prm' plug-in then the 'aex' one kicks in and alpha appears.

    This all used to work previously, but it appears that an Adobe updates have changed it. I'll put in a bug report to see what might be done.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  3. #3
    Thomas TV2
    Join Date
    May 2011
    Location
    copenhagen
    Posts
    92
    Hi Kane and thanks for a quick answer

    I will then try, with your hack, on a windowsPC then. I have only tried on a Mac :-)

    Thomas
    Tricaster 8000 AE2

  4. #4
    As an update, the 'aex' plug-in has been deprecated. All Adobe plug-in support is now handled by the 'prm' plug-in.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  5. #5
    Registered User
    Join Date
    Feb 2019
    Location
    Berlin
    Posts
    1
    Hi,

    i still have the problem that the NDI-stream has no alpha in After Effects. Premiere works just fine.

    Adobe CC 2020
    Ndi Tools 4.1
    Win10

  6. #6
    Registered User
    Join Date
    Mar 2007
    Location
    Aurora, IL
    Posts
    61
    I have the same issue in Win10, all CC apps current.
    JimK

    Tricaster 450, 460, 850, TC1

  7. #7
    As I understand it is a limitation of After Effects and '.prm' type plug-ins that Adobe needs to fix.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •