Results 1 to 6 of 6

Thread: Mojave vs lw 9.6

  1. #1
    Mad Doctor pixelinfected's Avatar
    Join Date
    Jan 2004
    Location
    Santa Margherita Ligure
    Posts
    615

    Mojave vs lw 9.6

    Today i talked with a friend that he had upgrade computer, and tried to move on it his lw license, but lightwave3d, never start.
    he had Mojave (like a new mac, and he cannot downgrade it), and Lightwave3d 9.6.
    he know a bit lightwave3d, and never update be cause 9.6 is enought for his work, upgrade it should be a lots of pain to leanr new software, a new render, node, and many other things that he not need, he use since two time at year the 3d.

    first time we start app we need to unlock system permission from preference panel, but later lightwave, modeler, hub told us that there is an error and contact developer.
    i tested 9.6.1 and also under sierra give me same error
    i know it's old, but it's so old? 2006 app...
    he really need to change software?
    any one can help me to help him?

    update:
    use batchmode to change permission to all folders and files, and package start under Sierra.
    Last edited by pixelinfected; 10-07-2019 at 08:54 AM. Reason: add info
    Danger! Mad Scientist at work

    I'm a mad genius, a mad scientist, someone like dr. jeckill and frankestein with a bit of Bugs Bunny.

  2. #2
    ack ack Markc's Avatar
    Join Date
    Feb 2006
    Location
    England
    Posts
    1,370
    Also note only LW 2018 and 2019 have the graphical fix in Mojave and display correctly.
    A lot of the buttons disappear on anything older than LW2018.
    This is a Mojave issue not LW, something in the os changed.
    This is why I have stayed on High Sierra.
    Mac Pro (2010) OSX 10.13 RX580 Pulse LW2019

  3. #3
    LW Watcher
    Join Date
    Feb 2003
    Location
    UK
    Posts
    1,488
    I haven't booted LW in ages, but 9.6.1 seems to work on Mojave but it won't handle any text at all.

    Click image for larger version. 

Name:	lw-test.png 
Views:	20 
Size:	529.7 KB 
ID:	146107

  4. #4
    ack ack Markc's Avatar
    Join Date
    Feb 2006
    Location
    England
    Posts
    1,370
    Paul, what do you mean regarding text?
    AFAIK anything older than 2018 half the buttons don’t display text properly on mojave.
    Mac Pro (2010) OSX 10.13 RX580 Pulse LW2019

  5. #5
    LW Watcher
    Join Date
    Feb 2003
    Location
    UK
    Posts
    1,488
    Quote Originally Posted by Markc View Post
    Paul, what do you mean regarding text?
    I can't create text inside modeller.

    AFAIK anything older than 2018 half the buttons don’t display text properly on mojave.
    Seems fine for me - did you see the screenshot?

  6. #6
    ack ack Markc's Avatar
    Join Date
    Feb 2006
    Location
    England
    Posts
    1,370
    Yep, your screenshot looks fine, as you say.....
    Maybe it doesn’t affect versions that old......?
    I know version 11 and 2015 are screwed.

    This is the thread showing the problem
    https://forums.newtek.com/showthread...ghlight=Mojave
    Last edited by Markc; 10-08-2019 at 12:10 PM.
    Mac Pro (2010) OSX 10.13 RX580 Pulse LW2019

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •