Results 1 to 15 of 15

Thread: Problem with Surface Smoothing in LW 2019

  1. #1

    Problem with Surface Smoothing in LW 2019

    Im having a huge problem with a simple surfacing problem in Lightwave 2019. I wonder if anyone else has experienced this?

    In the attached screenshot you can see a simple warship model. This model was originally a .obj file that has been opened in Modeller and resurfaced. The problem occurs the minute I tick "Smoothing".

    Click image for larger version. 

Name:	Screen Shot 2019-09-24 at 15.55.39.jpg 
Views:	173 
Size:	318.8 KB 
ID:	146048 Click image for larger version. 

Name:	Screen Shot 2019-09-24 at 16.18.26.jpg 
Views:	160 
Size:	286.5 KB 
ID:	146049

    After I have done that, it doesnt matter what I do, the smoothing can never be removed. Even unchecking "Smoothing" doesnt return the geometry to flat/unsmoothed.

    Also, adjusting the smooth threshold has no effect at all.

    I thought this was just a display issue in Modeller perhaps, but no - it displays and renders like this in Layout also.

    Ive had this problem with another stock model that I purchased recently, but it wasnt as noticeable as this case.

    Whats weird is the model displays and behaves normally in LW 2018.

    Any ideas?
    Scott

    Cape Town, South Africa
    http://www.youtube.com/user/independentvfx

  2. #2
    Heres the .lwo if anybody would like to give it a try on their side.

    Warship_simple.lwo.zip
    Scott

    Cape Town, South Africa
    http://www.youtube.com/user/independentvfx

  3. #3
    www.Digitawn.co.uk rustythe1's Avatar
    Join Date
    Feb 2006
    Location
    england
    Posts
    1,355
    cant download at the moment, but if you open the node panel is there anything plugged in anywhere? almost looks like a vertex normal problem or the surface is set to over 90deg smoothing, but its clear in your basic settings its not
    Intel i9 7980xe, Asus Rampage Vi extreme, 2x NVIDIA GTX1070ti, 64GB DDR4 3200 corsair vengeance,
    http://digitawn.co.uk https://www.shapeways.com/shops/digi...ction=Cars&s=0

  4. #4
    OK... OK....

    My bad. Problem solved - I did some reading and just found out about Smoothing Groups. I was able to select all the polygons in the object, launch the Smoothing Info window and then choose "Unassign" which I guess removes the smooth groups that must have been hidden in the original model. This seems to be what was causing the problem.

    I'll leave this post here in case it helps anyone else in future.
    Scott

    Cape Town, South Africa
    http://www.youtube.com/user/independentvfx

  5. #5
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    15,838
    Quote Originally Posted by scott.newman.ct View Post
    OK... OK....

    My bad. Problem solved - I did some reading and just found out about Smoothing Groups. I was able to select all the polygons in the object, launch the Smoothing Info window and then choose "Unassign" which I guess removes the smooth groups that must have been hidden in the original model. This seems to be what was causing the problem.

    I'll leave this post here in case it helps anyone else in future.
    I do not have any issues with it, once I load it in to Lightwave 2019.1.1..(layout) It loads with smoothing surfaces checked and active..thus smoothing is on, just need to unceck that in smoothing in layout and resave.
    And in modeler the surface is ofcourse the same, but how it looks in your viewport depends on what display mode you set obviously.

    So you do not have to select all polygons and unassign, in modeler it is however if not selected treated as selected item, just turn smoothing off there as well in the surface editor.
    Not sure why you got it differently in 2018 vs 2019, it should be the same surface..my guess may be that you used a different viewport setting or must have accidently turned smoothing off.

  6. #6
    Thanks Prometheus - You can see in my 2019 screenshot in the surface editor that the surface didnt have smotthing enabled yet it was displaying as smooth.

    I find this weird.
    Scott

    Cape Town, South Africa
    http://www.youtube.com/user/independentvfx

  7. #7
    Super Member
    Join Date
    Dec 2009
    Location
    London, England, UK
    Posts
    1,098
    Blog Entries
    18
    Quote Originally Posted by scott.newman.ct View Post
    Thanks Prometheus - You can see in my 2019 screenshot in the surface editor that the surface didnt have smotthing enabled yet it was displaying as smooth.

    I find this weird.
    That IS weird. Mac specific problem maybe?

  8. #8
    Quote Originally Posted by Shabazzy View Post
    That IS weird. Mac specific problem maybe?
    It goes away when I clear the smoothing groups from the model, so maybe it was that?
    Scott

    Cape Town, South Africa
    http://www.youtube.com/user/independentvfx

  9. #9
    Super Member
    Join Date
    Dec 2009
    Location
    London, England, UK
    Posts
    1,098
    Blog Entries
    18
    AFAIK in the surface editor, the smoothing button acts like a master switch for each individual surface name and so should override the settings of the respective surface's smoothing group.

    So if you have a surface with smoothing groups, you activate/deactivate them with the smoothing button in the surface editor. What you've stated is that deactivating the smoothing button doesn't change anything and that is weird because you shouldn't have to clear the smoothing groups for it to perform. Well, not with a LightWave created mesh anyway.

  10. #10
    Founding member raymondtrace's Avatar
    Join Date
    May 2003
    Location
    Ohio
    Posts
    1,011
    Quote Originally Posted by Shabazzy View Post
    That IS weird. Mac specific problem maybe?
    Nope. I replicated the smoothing issue on my Windows system, also running 2019.1.3. I also fix it by removing the smoothing group.

    Prometheus is reporting on 2019.1.1. So there's a possibly recent change.

    Is the original OBJ available for inspection?

    EDIT: I misread Prometheus' test and didn't notice it was tested in Layout. I don't think there's a difference in 2019.1.1 and 2019.1.3. The "smoothing" button in the "surface editor" works in 2019.1.3 Layout but not in 2019.1.3 Modeler. You must use the "smoothing info" window in Modeler to disable smoothing. The question remains: how the extreme degree of smoothing was originally assigned if it was not wanted. There could be a bug report to submit for Modeler...or there may have been something funky in the OBJ file.
    Last edited by raymondtrace; 09-24-2019 at 11:30 AM.
    LW4, 7.5D, 2015, 2018, 2019, 2020 running portably on a USB drive on an Amiga 2500 running Wine.

  11. #11
    Thanks for trying it out Raymondtrace, sure thing - here is the model in original .obj format

    Sovremenny_LOD1_OBJ.zip


    The object is a free Turbosquid model just in case anybody is wondering, here is the original link if you want to rather grab it from there: https://www.turbosquid.com/FullPrevi...cfm/ID/1415940
    Scott

    Cape Town, South Africa
    http://www.youtube.com/user/independentvfx

  12. #12
    Founding member raymondtrace's Avatar
    Join Date
    May 2003
    Location
    Ohio
    Posts
    1,011
    Now realizing that nothing may be wrong here in regard to 2018 vs 2019...

    See https://docs.lightwave3d.com/lw2019/...ce/interchange

    New 2019 feature...

    "OBJ Import

    LightWave will now import OBJs using Smoothing Groups and/or vertex color maps. Vertex Color maps need to be added to the surface nodal network with a Vertex Color node."

    This may still be something worthwhile to report to the LW devs... the smoothing info from the OBJ file is not being properly carried over to the LWO conversion (as demonstrated by the non-functioning "smoothing" button in LW Modeler).

    It looks like LightWave's default OBJ options may be an issue with this model. Go to "General Options"..."OBJ" to turn off "OBJ One Layer" and "OBJ Smoothing Groups" to better load this model.
    Last edited by raymondtrace; 09-24-2019 at 02:18 PM.
    LW4, 7.5D, 2015, 2018, 2019, 2020 running portably on a USB drive on an Amiga 2500 running Wine.

  13. #13
    Brilliant! Thanks raymondtrace. I think youre on the money. I got the below response from LW support:

    "did you recreate the smoothing groups?

    I would imagine that the OBJ came with setup smoothing groups - you can convert those over to LightWave smoothing groups with a command - wondering if you did or didn't do that step ?

    would help to have the original OBJ, to see what was provided."
    Scott

    Cape Town, South Africa
    http://www.youtube.com/user/independentvfx

  14. #14
    Yes as already mentioned just uncheck "OBJ Smooth groups" in OBJ properties panel and i'll be fine.
    This model was not created with special/proper smooth groups in it's origin creation app. 3DSMAX import's it same as LW and it's all clear when i look at *.obj file it has only ONE smooth group = all smooth/bubbly

    OBJ properties for import
    http://prntscr.com/paokgc

    Smooth group only 1
    http://prntscr.com/paomm8

    For proper smooth grouped model there should be s1, s2, s3, s4.... i.e. much more smooth groups for such low poly model.
    RAM-Studio
    WS - Dual Xeon E5-2698v4/128GB/Win10x64/4xRTX 2080Ti
    My LWM Video Car Modeling Tutorial

  15. #15
    Founding member raymondtrace's Avatar
    Join Date
    May 2003
    Location
    Ohio
    Posts
    1,011
    Quote Originally Posted by LW support
    ...you can convert those over to LightWave smoothing groups with a command...
    I'm wondering what that command is.
    LW4, 7.5D, 2015, 2018, 2019, 2020 running portably on a USB drive on an Amiga 2500 running Wine.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •