I downloaded version 3.8 but I cannot find a document with the system requirements. Can someone please point me to where I can find the system requirements?

Thank you.