Page 1 of 2 12 LastLast
Results 1 to 15 of 22

Thread: Fast manipulation, slow playback

  1. #1
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    586

    Fast manipulation, slow playback

    Why is playback so much slower than manipulation? I have built a rig for a centipede using spline control nodal motion and IK. I have one null that I can move to make the centipede crawl along the path with its 26 legs moving realistically. When I move the slider the centipede moves smoothly along the path with its little legs moving correctly, but if I animate the null instead playback is super choppy. It seems like layout is evaluating a bunch of crap that that doesn’t need evaluating every frame. This is a pretty general issue, a complex rig that can be manipulated smoothly will animate slowly. Why is this and is there something to be done to avoid it?

    I am not using subdivision or anything complex besides the nodal motion setup for the legs.

  2. #2
    I agree.
    All of the responses I've seen to this suggest the use of the preview system. In this way, you can even save and look at it in an external program whilst working on the next iteration.

    But it has never made sense that playback isn't 'live' in its speed. Maybe a good feature request would be to some how use the gpu for a preview. Here's to something faster.

  3. #3
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    586
    It seems like layout could use some sort of auto-caching or something so it doesn’t have to evaluate every little thing every single frame.

  4. #4
    Edit > OpenGL options > Geometry Acceleration > Set it to Buffered.

    Buffered is optimized for viewport movement and manipulation, whereas streaming is optimized for playback.
    Professional-level 3d training: Ryan's Lightwave Learning
    Plugin Developer: RR Tools for Lightwave

  5. #5
    Registered User ianr's Avatar
    Join Date
    Oct 2006
    Location
    Chiltern Riviera
    Posts
    1,400
    Quote Originally Posted by hypersuperduper View Post
    It seems like layout could use some sort of auto-caching or something so it doesn’t have to evaluate every little thing every single frame.

    I think that you should suggest this to Mr 'Duece' Jack Bennett II @ LW3dG. ( gpu acceleration wouldn't harm)

    AlSO the audio timeline lag (scrubbing) could be dealt with in the same coding pass, cos that has always been a pain.

    (2 for the price of 1) let us know how U get on ?

  6. #6
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    586
    Buffered does nothing. I don’t think this issue is GL performance related. It seems to be motion evaluation that causing the bottleneck. I will go ahead and file a bug report, but I don’t have much hope that it will lead anywhere. What it very strange is that it has no trouble evaluating the motion when I drag my controller only when I key the controller and try to playback the animation or scrub the slider.

  7. #7
    Are you certain? Does setting your viewport view mode to bounding box speed up the viewport?
    Professional-level 3d training: Ryan's Lightwave Learning
    Plugin Developer: RR Tools for Lightwave

  8. #8
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    586
    Nope. Bounding box mode does nada.

  9. #9
    Quote Originally Posted by hypersuperduper View Post
    Nope. Bounding box mode does nada.
    what is the polygon count on your model?
    Professional-level 3d training: Ryan's Lightwave Learning
    Plugin Developer: RR Tools for Lightwave

  10. #10
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    586
    Just shy of 20,000. so, not many.

  11. #11
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    586
    Reloading the scene improves performance. But it is still slower in playback than manipulation.

  12. #12
    Quote Originally Posted by hypersuperduper View Post
    Reloading the scene improves performance. But it is still slower in playback than manipulation.
    what happens if you replace the model with a null?
    Professional-level 3d training: Ryan's Lightwave Learning
    Plugin Developer: RR Tools for Lightwave

  13. #13
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    586
    Still slow. Disabling IK Seems to be the only thing that helps.

  14. #14
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    586
    By restarting and using the classic scene editor instead I got playback working somewhat better. There’s more going on with my scene however. Very strange stuff. The IK works properly when I move the controller, but when I play the timeline the feet miss their goals, but only sometimes. Very odd.

    here is a video of the weirdness

    Last edited by hypersuperduper; 08-18-2019 at 12:36 PM.

  15. #15
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    586
    Just an update: I received feedback from Newtek concerning the IK issue here. I filed a bug report and sent in the scene for them to look at. It has something to do with using spline control to control the heading and pitch of the spline nulls themselves. It sounds like they are looking into to it, They made it pretty clear that this should NOT be causing the IK to mess up, so it's a bug somewhere.

    So just a friendly reminder: FILE BUG REPORTS! the devs always respond and in this case they provided me with vital information, and hopefully going forward they will fix this issue.

    For those that don't know, Setting the Heading and pitch of the spline control nulls themselves to "Spline Control" has the effect of minimizing that annoying bank flipping issue with spline control and generally makes the spline more manageable to work wit. I have seen this solution recommended many times and have used it myself quite often usually without issue. However, clearly there are issues. Setting heading and pitch back to keyframe for these nulls fixes the IK issue even if the spline becomes fiddlier to work with.

    As for the speed difference in playback vs manipulation. That seems to have improved quite a lot. Perhaps the spline control bug was causing this as well.
    Last edited by hypersuperduper; 08-21-2019 at 02:57 AM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •