Results 1 to 2 of 2

Thread: AHK, imagesearch not working in LightWave

  1. #1

    AHK, imagesearch not working in LightWave



    Hello  any AHK users here?

    I'm having trouble making the "ImageSearch" command recognizing the LightWave Ui,

    solutions / hints / suggestions is much appreciated.


    as you can see, i got it to work in PhotoShop, but that's about it...  

    LW vidz   DPont donate   LightWiki   RHiggit   IKBooster   My vidz

  2. #2


    alright, getting closer, kinda works in LightWave now.



    CoordMode Pixel, Window
    CoordMode Mouse, Window
    #J::

    ImageSearch imagevarix, imagevariy, 0, 0, 1920, 1200, *60 scan1.gif
    MouseMove %imagevarix%, %imagevariy%


    if (ErrorLevel = 2)
    MsgBox Could not conduct the search.
    else if (ErrorLevel = 1)
    MsgBox Icon could not be found on the screen.
    else
    MsgBox The icon was found at %FoundX%x%FoundY%.

    return
    i had to add a value... *60
    why? from the AHK manual...

    *n (variation): Specify for n a number between 0 and 255 (inclusive) to indicate the allowed number of shades of variation in either direction for the intensity of the red, green, and blue components of each pixel's color. For example, *2 would allow two shades of variation. This parameter is helpful if the coloring of the image varies slightly or if ImageFile uses a format such as GIF or JPG that does not accurately represent an image on the screen. If you specify 255 shades of variation, all colors will match. The default is 0 shades.
    Last edited by erikals; 07-22-2019 at 12:25 PM.
    LW vidz   DPont donate   LightWiki   RHiggit   IKBooster   My vidz

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •