Page 1 of 2 12 LastLast
Results 1 to 15 of 22

Thread: Problem with missing polys in Layout

  1. #1

    Problem with missing polys in Layout

    I probably should have posed a question rather than titling my thread "Zombie Caster". Does anyone have any idea why this pixelation is happening in Layout? Looks fine when test rendered and in VPR.
    Click image for larger version. 

Name:	Zombie Coaster.jpg 
Views:	49 
Size:	413.7 KB 
ID:	145459

  2. #2
    Guessing maybe this is an OpenGL setting or something?

  3. #3
    Curmudgeon in Training Ma3rk's Avatar
    Join Date
    Mar 2003
    Location
    Near Beaverton, OR
    Posts
    1,392
    That looks like flipped polys frankly. Check in Modeler but might be some sort of surface attribute too.
    "Never be a cat in a cartoon. Never." Chief Wiggum

  4. #4
    Quote Originally Posted by Ma3rk View Post
    That looks like flipped polys frankly. Check in Modeler but might be some sort of surface attribute too.
    ok - so flipped polys will still display correctly in VPR and when rendered?

  5. #5
    Be sure Double Sided is turned off so you can better diagnose the issue.
    Tim Parsons
    Technical Designer
    Sauder Woodworking Co.

    http://www.sauder.com

  6. #6
    @Tim Parsons - will give that a try first chance I get. Thanks

    Must be something simple like that because it's only happening to the characters.
    The coaster car and the all of the other objects in the scene are displaying fine.

    Also I'm not sure why this would be but...maybe it's some strange thing having to do with the characters being displacement using MDD motion??
    I've got some troubleshooting to do...
    Last edited by stevegraymusic; 07-17-2019 at 12:09 PM.

  7. #7
    By chance are the characters purchased? If so look for doubled up polys and vertex normal map issues. BTW, how do they look in Modeler?
    Tim Parsons
    Technical Designer
    Sauder Woodworking Co.

    http://www.sauder.com

  8. #8
    Quote Originally Posted by Tim Parsons View Post
    By chance are the characters purchased? If so look for doubled up polys and vertex normal map issues. BTW, how do they look in Modeler?
    The female character was purchased and I made the nerdy guy in character creator. They look fine in Modeler.

  9. #9
    It turns out that if I save the models that I'm using as subpatched then they appear normally in the layout viewport. I didn't think that the models would have to be subpatched in order to appear smooth while animating the scene.
    The subpatched models slow layout down so much that it's difficult to animate, while the messy models play back animation in real time.
    Do I have to decide between looking at clean models while I'm working or animating the Zombies and seeing the clean models after rendering?

    I'm starting to think this is a models thing and not a Lightwave thing because I don't recall ever having this problem before.

  10. #10
    Registered User
    Join Date
    Aug 2016
    Location
    a place
    Posts
    1,828
    its the models. sometimes (quite often) on geometry created elseswhere you will get flipped polys. if you fix them and export back to the other 3d package, they will be flipperd there. have a look at modelers fix geo tools, they can help.
    if you have lwcad you can run fix errors but it can destroy uvs sometimes.
    for triangulated meshes, merge trigons uv’s works well, the best version is the x32 one. dpont made an update for x64 but its not as good at quadrangulating, there must be a slight difference.

    tldr; look for flipped polys, manually flip em, run trigon uvs and cleanup tools, triangulate any areas that are suspect.

  11. #11
    Frequenter
    Join Date
    Sep 2003
    Location
    Munich
    Posts
    349
    Quote Originally Posted by stevegraymusic View Post
    .... The subpatched models slow layout down so much that it's difficult to animate, ...
    You are aware that you can easily lower the subpatch level for the display in the viewport per object in their respective property panel, right?
    This effects only what you see in the viewport but renders the "original" subpatchlevel for output.

    Click image for larger version. 

Name:	AdjustDisplaySubpatchLevel_Layout.PNG 
Views:	21 
Size:	59.1 KB 
ID:	145509
    Last edited by fishhead; 07-18-2019 at 10:35 AM. Reason: bad typo... :-\

  12. #12
    @fishhead
    Thanks! Yes - I remember seeing that option before. I should try that. I've tried everything else.
    It didn't dawn on me to try it because these are not really high poly characters.
    Even DAZ characters which are usually pretty high poly never slowed down animation in Layout for me.

    Perhaps it is the fact that I have so much else going on. There is a full animated roller coaster in the scene in addition to the main characters.
    I was also hoping to add other riders and at this rate I may have to greenscreen them in.

  13. #13


    could be the Render settings,
    check these >

    Ray Recursion Limit
    Ray Precision
    Ray Cutoff
    LW vidz   DPont donate   LightWiki   RHiggit   IKBooster   My vidz

  14. #14
    Quote Originally Posted by erikals View Post

    could be the Render settings,
    check these >

    Ray Recursion Limit
    Ray Precision
    Ray Cutoff
    It shows up in OpenGL not while rendering so those settings are not going to help.
    Tim Parsons
    Technical Designer
    Sauder Woodworking Co.

    http://www.sauder.com

  15. #15


    oh, hmm...    
    LW vidz   DPont donate   LightWiki   RHiggit   IKBooster   My vidz

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •