Results 1 to 5 of 5

Thread: Lightwave 2019 grainy motion blur

  1. #1
    Wary Lamb Rejoining Flock Scott Gammans's Avatar
    Join Date
    May 2003
    Location
    Suburban Washington, DC
    Posts
    258

    Lightwave 2019 grainy motion blur

    I am going a bit mad trying to increase the quality of motion blur in a 104-frame Lightwave 2019.0.3 scene that uses the Perspective camera and an object in motion that is surfaced with a mixture of Principled BSDF, Dielectric, and Conductor materials. There are no particles or volumetrics in the scene.

    The object (from the POV of the camera) enters the scene from the upper left corner of the frame and flies towards and under the camera to exit the lower right corner of the scene by frame 104. The object is not deforming, just bookin’ along at about 190 MPH (relative to the camera), so there’s considerable motion blur that occurs towards the end, but it looks very “granular” at the edges of the model, and no matter what I try I cannot seem to get the darn thing to smooth out.

    Coming from Lightwave 9.6 to 2019, I am more than a little confused by which settings I need to tweak. Adding more subframes does not seem to do anything, and I don’t want to increase the blur length past 50% (it doesn’t look right). The scene is being rendered with global illumination and a single area light. GI isn’t flickering (thank the maker), so it’s all down to fixing the blur and I’m good to go.

    Motion Blur settings:
    • Particle Blur - off
    • Blur Length - 50%
    • Subframes - I’ve gone as high as 24; doesn’t seem to have any effect
    • Shutter Open - 0%
    • Shutter Efficiency - 100%
    • Rolling Shutter - 0%


    Anti-aliasing settings:
    • Minimum Samples - 1
    • Maximum Samples - 32
    • Adaptive Sampling - enabled
    • Threshold - 0.01
    • Filter Radius - 0.1
    • All render buffers using Gaussian reconstruction


    GI:
    • Interpolated - enabled
    • Primary Rays - 1500
    • Secondary Rays - 500
    • Minimum Pixel Spacing - 5
    • Maximum Pixel Spacing - 10
    • Angular Tolerance - 45%
    • Interpolation Softness - 100%
    • Behind Test - enabled
    • Use Bumps - off
    • Animation - enabled
    • Frame Step - 1
    • Scene is baked and locked prior to rendering


    Other render settings:
    • Area Light Samples - 4
    • Diffuse Bounces - 2
    • Ray Recursion Limit - 6
    • Transparency Recursion Limit - 6
    • Reflection Recursion Limit - 4
    • Refraction Recursion Limit - 4
    • Ray Precision - 6.0
    • Reflection Samples - 6
    • Refraction Samples - 6 (I have noticed that upping this improves the graininess on translucent materials...)
    • Subsurface Scattering Samples - 1
    • Enable Despike - off
    • Noise Filter - off (I really hope this isn't the problem... the noise filter seems to really soften the rendered images...)


    Any suggestions?? Thanks!
    Last edited by Scott Gammans; 06-28-2019 at 05:41 AM. Reason: Added some additional settings

  2. #2
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,793
    If the graininess you don't like is when the Object is speeding past close to the Camera, you might have some luck putting an Envelope on the Subframes to increase the subframe count substantially as the Object passes the Camera. Maybe 20 subframes when the Object first enters the frame, and then 200-300 when it's passing close to the Camera.

    For an animation, I don't think it's useful to look at single frames as if they were separate entities. The whole point of Motion Blur is to interpolate the distance the object moves along its path while the camera shutter is open. So, for an animation, I'd recommend looking at the sequence at full speed to see if the simulated motion blur produced by LW is acceptable rather than looking at the individual frames.

    Good luck!
    mTp

  3. #3
    Goes bump in the night RebelHill's Avatar
    Join Date
    Nov 2003
    Location
    jersey
    Posts
    5,766
    MB is a camera effect... as such, the only real fix is more camera samples. For extreme blurs, they might need to go very high (like 100+). Ofc, that'll be something of a killer rendertime wise, so I'd recommend only rendering out those few frames at such high a setting where it's needed.

    Also, or instead, you can increase the filter radius substantially (like 1.5 to 3). This will just blur the crap outta your render, so again best used on just those frames where its needed.
    LSR Surface and Rendering Tuts.
    RHiggit Rigging and Animation Tools
    RHA Animation Tutorials
    RHR Rigging Tutorials
    RHN Nodal Tutorials
    YT Vids Tuts for all

  4. #4
    Wary Lamb Rejoining Flock Scott Gammans's Avatar
    Join Date
    May 2003
    Location
    Suburban Washington, DC
    Posts
    258
    Excellent suggestions and good point regarding trying to evaluate the look just from one frame.

    I’ve noticed the Conductor and DiElectric materials (and the Principled BSDF materials with low roughness/high specularity) often cause a lot of “sparklies”, but I think that’s the phenomenon reported in another thread so I’ll try the recommendations over there.

    Thanks guys.

  5. #5
    Quote Originally Posted by Scott Gammans View Post
    Excellent suggestions and good point regarding trying to evaluate the look just from one frame.

    I’ve noticed the Conductor and DiElectric materials (and the Principled BSDF materials with low roughness/high specularity) often cause a lot of “sparklies”, but I think that’s the phenomenon reported in another thread so I’ll try the recommendations over there.

    Thanks guys.
    Another good option is to save the Motion buffer when rendering. This way you can render without motion blur and then do it in post, where you can get a smooth look without increasing your render times. You will need something like Real Smart Motion Blur plugin if you are comping in After Effects.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •