Results 1 to 5 of 5

Thread: Content Path problem--Layout can't find objects on loading scene

  1. #1

    Content Path problem--Layout can't find objects on loading scene

    LW 2019.03 on MacOS 10.13.6

    I updated to the new LW recently and no matter how I set my content path and arrange my file structure, Layout can't seem to find objects when loading scene files. I have to hand select each object even though the content path is pointing directly to my object directory. (I've also tried setting the path to a higher directory which includes both scene and object directories.) What am I doing wrong?

    Thanks in advance.

  2. #2
    Registered User
    Join Date
    Jan 2005
    Colorado Springs
    I'm on Windows rather than a Mac, but the times I run into needing to select the Objects or Images while loading a scene are when the Scene was saved with "outside references", i.e. includes files that were not in subfolders of the current Content directory tree when the scene was saved. But even then, when I navigate to the correct folder, select the first Object or Image, Layout will use that path for all the remaining Object / Image loads.

    Is the Objects folder named "Objects"? In Layout, the Edit=>Paths Options... panel shows the required names for each of the Content Directory's subfolders:

    Click image for larger version. 

Name:	01_PathsOptions.jpg 
Views:	13 
Size:	173.9 KB 
ID:	145158

    Finally, since LWS files in LW are text files, you might bring up the problem LWS file in a text editor, search for "LoadObject" and take a look at the path name(s) stored in the LWS file and try to debug the problem based upon that string. For example, in one of my scene files the LoadObjectLayer command references an Object in the Content Directory tree:

    LoadObjectLayer 1 10000000 Objects/Sphere_StarMapped.lwo

    while an "outside reference" looks like this (again, Windows path syntax rather than Mac):

    LoadObjectLayer 1 10000000 C:Newtek/Space/Objects/Stars_MTP.lwo

    Good luck!

  3. #3
    Thanks mTp

    I tried renaming my subfolders as you suggest, still no luck. Even when I hand select the first object, Layout still asks for all subsequent ones though they are in same directory-- so something weird's going on. And I do have autodetect on.

    Meanwhile Layout is behaving very poorly-- lots of crashes, and when open still takes 5-10 seconds for it to function when I switch to it from modeler. I'm wondering if this is an OS problem?

  4. #4
    Okay I've got this more or less resolved -- thanks to mTp and a couple of videos from NewTek on creating paths and directories: the first 2 on this page

    I used the "create directories" setup in the path options, then moved my objects and scenes into the new folders. BUT it still wasn't loading properly from my original file tree-- it only worked when I moved the content path out of a folder that had a number of other lightwave projects in their own folders, with separate file trees. It's a weird bug, but if anyone has the same problem try a test where you keep moving your content directory to different places. Point to it from the paths options, and see if it loads correctly.

  5. #5
    Here at work, we have some macs running 2019.0.3. Can't say I've seen this bug and all content is located 'elsewhere' on the network.

    The delay is affecting all versions, from my experience: mac and pc. It is an odd occurrence as it shows under lots of memory had or not, a lot of other programs open or not. The only thing I can say makes a difference is if you haven't opened a ms product. This combo, lw+ms, kill my system. Dunno why.
    A restart clears it up.
    Robert Wilson, MA Deaf Ed.
    Indiana Deaf School
    This e-mail may contain information protected under the Family Educational Rights and Privacy Act.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts