Results 1 to 9 of 9

Thread: bump map banding

  1. #1
    Registered User Captain Chaos's Avatar
    Join Date
    Oct 2006
    Location
    Philadelphia
    Posts
    149

    bump map banding

    Getting these wicked steps on my bump maps. any way top get rid of themClick image for larger version. 

Name:	Screen Shot 2019-06-03 at 3.36.34 PM.png 
Views:	63 
Size:	3.29 MB 
ID:	145150

  2. #2
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,795
    It seems like whatever source you used for the Bump Map provided a pixelated image? Is "Pixel Blending" and "Use Mipmaps" enabled for that image? If you can go back to the provider of the Bump Map image and get a non-pixelated image, that might be best.

    If the only image you have is pixelated, you might have some success smoothing it out with the Full Precision Blur image processing option in the Image Editor:

    Click image for larger version. 

Name:	01_PixelatedBumpMap.jpg 
Views:	32 
Size:	1.20 MB 
ID:	145151 Pixelated Bump Map image

    Click image for larger version. 

Name:	02_PixelatedBumpMap_FullPrecisionBlurAdded.jpg 
Views:	32 
Size:	1.15 MB 
ID:	145152 Adding Full Precision Blur to smooth it out

    Good luck!
    mTp

  3. #3
    Registered User Captain Chaos's Avatar
    Join Date
    Oct 2006
    Location
    Philadelphia
    Posts
    149
    Thanks. I made the original image and there's no pixelation in it. I'm still on the old lightwave but the mipmap thing helped a lot.

  4. #4
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,795
    OK. You may need a higher resolution image for the Bump Map image.

    Full Precision Blur is available in the Image Editor=>Processing tab since LW11 or before.

    mTp

  5. #5
    Registered User Captain Chaos's Avatar
    Join Date
    Oct 2006
    Location
    Philadelphia
    Posts
    149
    Quote Originally Posted by MonroePoteet View Post
    OK. You may need a higher resolution image for the Bump Map image.

    Full Precision Blur is available in the Image Editor=>Processing tab since LW11 or before.

    mTp
    Nice, I didn't know that was there. I've always done everything in Photoshop. BTW, as an experiment I quadrupled the resolution of of the bump map image in Photoshop and it didn't look any different.

  6. #6
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,795
    Very weird that increasing the resolution didn't reduce / eliminate the jaggy pixelated edges! As I mentioned, be sure "Pixel Blending" and "Use Mipmaps" are enabled for that Image, both in the Image Editor and in the Texture layer, and maybe bump up the Mipmap value.

    mTp

  7. #7
    Super Member
    Join Date
    Dec 2009
    Location
    London, England, UK
    Posts
    1,081
    Blog Entries
    18
    It looks like your original source image was saved to a file with a lower bit per pixel value than 24. It looks like it was saved at 8 bits or lower. You might want to try re-saving the image from Photoshop as a 24 bit file (I'd make it a png) and see where that takes you.

  8. #8
    Registered User
    Join Date
    Mar 2012
    Location
    Socal
    Posts
    403
    This has nothing to do with resolution. It is color quantization related. You'll want to use more than 8 bits per channel, or do a full-precision blur filter to it after loading it, or the mip-map trick might help.

  9. #9
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,795
    Quote Originally Posted by Dan Ritchie View Post
    This has nothing to do with resolution. It is color quantization related. You'll want to use more than 8 bits per channel, or do a full-precision blur filter to it after loading it, or the mip-map trick might help.
    OK, thanks. Yes, looking more closely the jagged edges aren't consistent enough and evenly spaced enough to be a resolution granularity issue.

    Thanks again,
    mTp

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •