Results 1 to 6 of 6

Thread: No video receive with Pi3 on Embedded SDK 3.8

  1. #1
    Registered User
    Join Date
    Feb 2019
    Location
    Montreal
    Posts
    4

    No video receive with Pi3 on Embedded SDK 3.8

    I've compiled ffmpeg with ndi on linux Ubuntu x86 and manage to receive video, audio and metadata. This is great.
    However, doing the same on Pi3 will only get me audio and metadata, but no video packets on reception.
    Everything compiles and links fine using armv8-rpi3-linux-gnueabihf.

    thardie posted a similar problem compiling the NDI_Recv sample and I would like to know if this is expected behavior.
    Here's the link https://forums.newtek.com/showthread...=1#post1544352

  2. #2
    The NDI SDK for ARM doesn't have a video decoder.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  3. #3
    Registered User
    Join Date
    Feb 2019
    Location
    Montreal
    Posts
    4
    Do you plan on providing this in a future version?

    Thanks for the speedy answer!

  4. #4
    I'm not on the development team, I do know the road map.

    I think the more near term solution will be to use the NDI Embedded SDK to decode on FPGA (when decode becomes available) with an ARM CPU to handle the network stack and other aspects of your application.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  5. #5
    Sorry, that is I do 'not' know the road map.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  6. #6
    Registered User
    Join Date
    Feb 2019
    Location
    Montreal
    Posts
    4
    Thanks for the heads up!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •