Page 7 of 8 FirstFirst ... 5678 LastLast
Results 91 to 105 of 117

Thread: Open Image Denoise node for DP Filter

  1. #91
    Registered User
    Join Date
    Mar 2018
    Location
    Perth, Australia
    Posts
    158
    Quote Originally Posted by dpont View Post
    OpenImageDenoise has been updated to version 1.2.0,
    download the windows dynamic libraries (dll) oidn-1.2.0.x64.vc14.windows.zip
    or Mac shared libraries (dylib) oidn-1.2.0.x86_64.macos.tar.gz
    here:
    https://github.com/OpenImageDenoise/oidn/releases/
    ...
    Denis.
    Thanks!

  2. #92
    Member
    Join Date
    May 2006
    Location
    France
    Posts
    4,208
    A few notes about the installation of OpenImageDenoise 2018 node with Lightwave 2020.

    The LW2020 tbb library is compatible with OIDN tbb library.
    So with LW2020, when installing OpenImageDenoise 2018 node
    no more need to replace the tbb library in LW/bin.

    Also for those, using an old copy of DP Filter 2018,
    you may have a crash when opening the node editor,
    while it is still working with LW2020,
    you may need to download a recent version of DP Filter 2018.

    Denis.

  3. #93
    Registered User
    Join Date
    May 2003
    Location
    Ireland
    Posts
    154
    Thanks Denis
    This is Brilliant. your contributions to Lightwave are (as usual) Simply Brilliant.
    This is very much appreciated
    Regards Pat

  4. #94
    Registered User gdkeast's Avatar
    Join Date
    Jul 2017
    Location
    Middle of nowhere
    Posts
    281
    Yes, merci beaucoup for keeping your plug-ins current. They've always been one of my favorites things about LW!

  5. #95
    Member
    Join Date
    May 2006
    Location
    France
    Posts
    4,208
    OpenImage Denoiser has been updated to version 1.2.1,
    https://github.com/OpenImageDenoise/oidn/releases/

    For Windows download
    oidn-1.2.1.x64.vc14.windows.zip
    For MacUB
    oidn-1.2.1.x86_64.macos.tar.gz


    -Fixed tiling artifacts when in-place denoising (using one of the input
    images as the output) high-resolution (> 1080p) images
    -Fixed ghosting/color bleeding artifacts in black regions when using
    albedo/normal buffers

    No change in the DP Filter node, except a node editor context filter,
    so the node is only listednow in the Image Filter node editor,
    so the node should be removed and this version re-added,
    OIDB libraries copied in the same plugin folder.

    See the readmefile for a fresh installation,
    in Mac 2020.0.1 the tbb trick is still necessary for the moment.


    Denis.
    Last edited by dpont; 06-16-2020 at 02:13 AM.

  6. #96
    geo messy madno's Avatar
    Join Date
    Feb 2009
    Location
    Germany
    Posts
    848
    Many thanks!

  7. #97
    Super Member
    Join Date
    Aug 2016
    Location
    a place
    Posts
    2,484
    thankyou very much denis

  8. #98
    Member
    Join Date
    May 2006
    Location
    France
    Posts
    4,208
    OpenImage Denoiser has been updated to version 1.2.2 recently,
    this is a minor update, if you are using version 1.2.1, you can skip it.

    Mac UB version of the OIDN node can now be installed directly in LW 2020.0.2,
    without any change in /bin folder of LW, this is a fix in LW,
    no need to re-download the node or OIDN package.

    Denis.

  9. #99
    Registered User
    Join Date
    Mar 2018
    Location
    Perth, Australia
    Posts
    158
    Quote Originally Posted by dpont View Post
    OpenImage Denoiser has been updated to version 1.2.2 recently,
    this is a minor update, if you are using version 1.2.1, you can skip it.

    Mac UB version of the OIDN node can now be installed directly in LW 2020.0.2,
    without any change in /bin folder of LW, this is a fix in LW,
    no need to re-download the node or OIDN package.

    Denis.
    Thanks Denis for both the headsup on OIDN as well as LW2020.0.2! I have posted a thread about that as there was none. I would have thought Newtek would send an e-mail to its users..... or make a post themselves onto the forum. Weird how they operate.

  10. #100
    Member
    Join Date
    May 2006
    Location
    France
    Posts
    4,208
    Another minor update, OIDN v1.2.3
    https://github.com/OpenImageDenoise/oidn/releases/

    Related to specific set of instructions with Intel processors.

    Denis.

  11. #101
    Registered User
    Join Date
    Feb 2005
    Location
    Barcelona
    Posts
    334
    Can't wait to get back, installed, and tested it! I finally may be able to use 2018 PBR finally with more complex and detailed scenes so yeah, probably you have made 2018 production ready, amazing Dennis!

    Anyone's already tested it for animation? Thanks!

  12. #102
    Member
    Join Date
    May 2006
    Location
    France
    Posts
    4,208
    Quote Originally Posted by inakito View Post
    ...Anyone's already tested it for animation? Thanks!
    Not temporal, but may be you can find a compromise.

    This has been discussed here,
    https://forums.newtek.com/showthread...=1#post1586126


    Denis.

  13. #103
    Registered User
    Join Date
    Oct 2013
    Location
    UK
    Posts
    58
    Hello there.

    I need some help please

    I am struggling to install the plugin on my MAC on LW2018. I am getting a "plugins were not found or could not be added" message. I've read the read me file and followed the instructions.

    The image filter plug in is installed and working
    The OpenDenoiser plug in file is in Lightwave plug in folder-(it's the right one for LW2018-19)
    The libtbb.1.0.0.dylib is in lightwave bin folder as instructed (followed the procedure)
    The dynamic libraries are -- I think-- in the right place. Went to usr/local/lib using "go to folder" command However once I get to local there is no "lib" folder inside. Dropped the files in there, but it's not working. Do I need to create a folder called "lib"?

    What Am I doing wrong?
    Space Emotion - Architecture - www.space-emotion.com

  14. #104
    Member
    Join Date
    May 2006
    Location
    France
    Posts
    4,208
    Quote Originally Posted by luzlight View Post
    ... Went to usr/local/lib using "go to folder" command However once I get to local there is no "lib" folder inside.
    Dropped the files in there, but it's not working. Do I need to create a folder called "lib"?...
    Not sure if I can help,
    as I remember I didn't create this "lib" folder, in Yosemite, neither in HighSierra,
    don't know what is your OS,
    as you can see in mine, there were alreary several libraries in this folder.

    Click image for larger version. 

Name:	HighSierra_lib.png 
Views:	6 
Size:	93.2 KB 
ID:	148756

    Denis.
    Last edited by dpont; 09-24-2020 at 09:14 AM.

  15. #105
    Registered User
    Join Date
    Oct 2013
    Location
    UK
    Posts
    58
    Thanks Denis

    Turns out that there are several ".usr" directories. It seems that each user as one (I'got several user accounts on my mac). I was dropping the files in one of those.

    But your screen shot gave me the clue, so it has to be done in the "general" (probably the wrong name) .usr directory.

    It worked !!. It said 2 plug-ins had been loaded. I can finally see the OpenImageDenoise node.

    This is difficult for the non-programmers, like me !.

    Many thanks.
    Last edited by luzlight; 09-24-2020 at 07:57 AM.
    Space Emotion - Architecture - www.space-emotion.com

Page 7 of 8 FirstFirst ... 5678 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •