Results 1 to 10 of 10

Thread: LW 2019 Smoothing groups

  1. #1
    Super Member kolby's Avatar
    Join Date
    Aug 2004
    Location
    CZ, EU
    Posts
    393

    LW 2019 Smoothing groups

    I have a question about the smoothing groups. I've created several smoothing groups on my model but in the Layout my model is without any smoothing ? Did I miss something ?
    System info: CPU: Xeon X5680 RAM: 12GB DDR3/1333MHz MB: Asus P6T WS Pro GFX: Asus GTX 750 Ti / 2GB OS: Win7, LW2018.0.7 x64

  2. #2
    I tested this and it is interesting.

    Default material in Modeler is Principled BSDF with turned off smoothing. When you set smoothing groups in Modeler you see result but smoothing in surface is still turned off.
    When you save object and send to Layout then like you wrote, smoothing groups are not visible. You must turn on smoothing in surface. In my opinion you can send a bug report. Layout should see smoothing groups like Modeler.

  3. #3
    Super Member kolby's Avatar
    Join Date
    Aug 2004
    Location
    CZ, EU
    Posts
    393
    If you turn on smoothing in surface, smoothing groups are visible in OGL, but smoothing in the rendered image is wrong.
    Bug report sent.
    System info: CPU: Xeon X5680 RAM: 12GB DDR3/1333MHz MB: Asus P6T WS Pro GFX: Asus GTX 750 Ti / 2GB OS: Win7, LW2018.0.7 x64

  4. #4
    It's been reported (by me and several others from what i can see in the system).

    So yes, it's a BUG.
    RAM-Studio
    WS - Dual Xeon E5-2698v4/128GB/Win10x64/x TitanX(M) + 2x GTX 1080Ti + GTX 1080
    My LWM Video Car Modeling Tutorial

  5. #5
    It's been reported (by me and several others from what i can see in the system).

    So yes, it's a BUG.
    RAM-Studio
    WS - Dual Xeon E5-2698v4/128GB/Win10x64/x TitanX(M) + 2x GTX 1080Ti + GTX 1080
    My LWM Video Car Modeling Tutorial

  6. #6
    Member
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    161
    It is still broken in 2019.0.3, right?
    LightWave 3D 2019 (Win64)

  7. #7
    Super Member XswampyX's Avatar
    Join Date
    Aug 2010
    Location
    Kernow
    Posts
    2,078
    Quote Originally Posted by SaT View Post
    It is still broken in 2019.0.3, right?
    It works here?
    Attached Files Attached Files

  8. #8
    Member
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    161
    Thanks for your test scene. Now I know why it did not work for me. I always did not check the smoothing option in the Surface Editor when using Smoothing Groups because the Smoothing Threshold is not used for this.
    LightWave 3D 2019 (Win64)

  9. #9
    Super Member XswampyX's Avatar
    Join Date
    Aug 2010
    Location
    Kernow
    Posts
    2,078
    Quote Originally Posted by SaT View Post
    Thanks for your test scene. Now I know why it did not work for me. I always did not check the smoothing option in the Surface Editor when using Smoothing Groups because the Smoothing Threshold is not used for this.
    Yes. It's a strange thing, but if you have smoothing groups then you don't need a smoothing threshold.

    Cheers!

  10. #10
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,511
    Quote Originally Posted by XswampyX View Post
    Yes. It's a strange thing, but if you have smoothing groups then you don't need a smoothing threshold.
    That's really a bug, though. If there really needs to be a global enable/disable to smoothing groups' effects, it should exist as an independent, object-level property. Having surface-scope properties controlling object-scope attributes just creates a bunch of odd corner cases (read as: bugs), as well as import/export inconsistencies.

    At the very least, if per-surface Smoothing must be enabled to allow smoothing groups' effects, then that control ought to be auto-enabled for all surfaces applied to objects' geometry where active smoothing groups are present. Having it work otherwise just creates confusion and problems.
    John W.
    LW2015.3UB/2019.1.4 on MacPro(12C/24T/10.13.6),32GB RAM, NV 980ti

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •