Results 1 to 6 of 6

Thread: Open GL issue LW2018

  1. #1
    Registered User
    Join Date
    Oct 2013
    Location
    UK
    Posts
    43

    Open GL issue LW2018

    Hello:

    Mapped textures have stopped showing up in open GL in layout.

    Any ideas as to why this might be happening?. It was working fine and suddenly it was gone. Can't remember exactly what I was doing when it happened.

    Uninstalled LW and reinstalled (didn't erase config files) and issue is still there.

    Textures show up in modeller fine.

    It renders fine, it's jus the Open GL preview. The option is checked in the Open GL options tab.

    Mac OS 10.10.5 Latest LW2018 build.

    Thanks,

  2. #2
    Registered User
    Join Date
    Sep 2015
    Location
    Sweden
    Posts
    587
    Is a material with the textured color connected to the gl output in the texture node editor? I have accidentally disconnected them before and lost textures in gl view. Try connecting the color output of the texture node to a standard shader and then connect that to gl only. You can leave everything else where it is so you don’t mess up your proper rendered material.

  3. #3
    ack ack Markc's Avatar
    Join Date
    Feb 2006
    Location
    England
    Posts
    1,370
    Change the Shading Method in the GL prefs panel to PBRGLSLShaders.
    Mac Pro (2010) OSX 10.13 RX580 Pulse LW2019

  4. #4
    Registered User
    Join Date
    Oct 2013
    Location
    UK
    Posts
    43
    Quote Originally Posted by hypersuperduper View Post
    Is a material with the textured color connected to the gl output in the texture node editor? I have accidentally disconnected them before and lost textures in gl view. Try connecting the color output of the texture node to a standard shader and then connect that to gl only. You can leave everything else where it is so you don’t mess up your proper rendered material.
    Hi it's just simple texture maps loaded into the image node which is itself connected into the color input of the material node. The simplest of all nodal arrangements. It is not one texture that has disappeared from view, it is all of them, so I am seeing a lot of white-ish polygons in the layout viewport when choosing "textured solid shaded wireframe" mode. VPR is fine, renders are fine as everything shows up.

    I am in the middle of a deadline so I'll investigate further later on when I am finished. Thanks for your suggestion, I'll try.

  5. #5
    Registered User
    Join Date
    Oct 2013
    Location
    UK
    Posts
    43
    Quote Originally Posted by Markc View Post
    Change the Shading Method in the GL prefs panel to PBRGLSLShaders.
    Hi thanks, It was already selected, so tried the other options and then back to it but nothing happened. The issue isn't a game stopper it's just a slight inconvenience. I'll try to sort it out once I render all the images. Thanks for your help.

  6. #6
    LightWave documentation BeeVee's Avatar
    Join Date
    Feb 2003
    Location
    Pessac
    Posts
    5,074
    You can use the OpenGL input on the Surface destination node to have something display. Have you got something attached there by mistake that is overriding your display?

    B
    Ben Vost - NewTek LightWave 3D development
    LightWave 3D Trial Edition
    AMD Threadripper 1950X, Windows 10 Pro 64-bit, 32GB RAM, nVidia GeForce GTX 1050Ti (4GB and 768 CUDA cores) and GTX 1080 (8GB and 2560 CUDA cores) driver version 430.86
    AMD FX8350 4.2 GHz, Windows 7 SP1 Home Premium 64-bit, 16GB RAM, nVidia GeForce GTX 1050Ti (416.34, 4GB and 768 CUDA cores)
    Dell Server, Windows 10 Pro, Intel Xeon E3-1220 @3.10 GHz, 8 GB RAM, Quadro K620
    Laptop with Intel i7, nVidia Quadro 2000Mw/ 2GB (377.83 and 192 CUDA cores), Windows 10 Professional 64-bit, 8GB RAM
    Mac Mini 2.26 GHz Core 2 Duo, 4 GB RAM, 10.10.3

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •