Results 1 to 12 of 12

Thread: Updated Nvidia Driver Now TriCaster Won't Start

  1. #1
    Registered User stanarthur's Avatar
    Join Date
    Jun 2013
    Location
    Florida
    Posts
    59

    Updated Nvidia Driver Now TriCaster Won't Start

    I'm getting a GPU error, "Unable to verify video drivers" and it opens the Nvidia driver download page I just previously used to download and install the Jan15, 2019 driver.
    Last edited by stanarthur; 02-01-2019 at 11:10 AM.
    TriCaster Mini SDI Advanced Edition 2 Build 5-1-180323C
    Talkshow

  2. #2
    Registered User
    Join Date
    Apr 2008
    Location
    Racine
    Posts
    1,655
    Go back to a version 399 graphics driver for now, that should work

    Thanks

    Jeff
    Jeff Pulera
    Streaming Broadcast Solutions - Newtek Elite

    TriCasters: Mini with AE, TC1
    Camera: Sony PMW-X70 4K
    Controllers: All variety of XKeys
    PTZ: Newtek NDIHX-PTZ1

  3. #3
    Registered User stanarthur's Avatar
    Join Date
    Jun 2013
    Location
    Florida
    Posts
    59
    It took some doing because I had done a clean install that wiped out v399. I eventually got it back, though.
    TriCaster Mini SDI Advanced Edition 2 Build 5-1-180323C
    Talkshow

  4. #4
    Registered User
    Join Date
    Apr 2008
    Location
    Racine
    Posts
    1,655
    Quote Originally Posted by stanarthur View Post
    It took some doing because I had done a clean install that wiped out v399. I eventually got it back, though.
    Not sure what that means, just download graphics drivers from nvidia.com as needed
    Jeff Pulera
    Streaming Broadcast Solutions - Newtek Elite

    TriCasters: Mini with AE, TC1
    Camera: Sony PMW-X70 4K
    Controllers: All variety of XKeys
    PTZ: Newtek NDIHX-PTZ1

  5. #5
    Quote Originally Posted by JPulera View Post
    Not sure what that means, just download graphics drivers from nvidia.com as needed
    nVidia has released so many driver versions since 399, that it isn't on the list anymore when you search for it.

    Latest versions of TriCaster AE2 (and AE3) are compatible with nVidia 400+ driver versions.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  6. #6
    Registered User rsilva's Avatar
    Join Date
    Apr 2016
    Location
    Lisboa
    Posts
    32
    Quote Originally Posted by kanep View Post
    nVidia has released so many driver versions since 399, that it isn't on the list anymore when you search for it.

    Latest versions of TriCaster AE2 (and AE3) are compatible with nVidia 400+ driver versions.
    And about TC1 with last firmware (7-0-190130). What's the recommended nvidia driver version?

  7. #7
    If the TC1 isn't telling you to update, then you are on a recommended version.
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  8. #8
    Registered User
    Join Date
    Sep 2014
    Location
    London
    Posts
    98
    Trying to update my drivers for the AE3 Checker, 399 is too old for the checker, 418 is too new for the Tricaster I'm on 5-1-180323C which is pretty old so that's probably why. Good news is any version newer than 399 seems to pass the checks.
    Last edited by dtweek; 02-12-2019 at 04:51 AM.

  9. #9
    Grizzled Veteran jcupp's Avatar
    Join Date
    Feb 2003
    Location
    Bloomington, IN
    Posts
    1,617
    You can download older (i.e. v399.x) nvidia drivers here: https://www.nvidia.com/Download/Find.aspx?lang=en-us
    -Jeff


    My TriCaster Blog
    TriCaster Tally Lights

    Gear Used: TC1, NC1 I/O, TC 460, TC Mini 4i, TS 100, TS 4000

  10. #10
    Just to make it easier, here are direct links to the 399 drivers for both Windows 10 and Windows 7, using the link that Jeff posted above.

    Windows 7 (Mini, 410, 460, 860, 8000 systems)
    https://www.nvidia.com/download/driv...x/137725/en-us

    Windows 10 (TC1, VMC1, 3P1 systems)
    https://www.nvidia.com/download/driv...x/137727/en-us
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

  11. #11
    Registered User
    Join Date
    Nov 2012
    Location
    Worcester, UK
    Posts
    146
    I also had nVidea drivers V 399 on my Mini and to check compatibility I have just installed drivers 418.91 as per Kanes instructions above.

    Although the test program re AE3 has confirmed my machine will run it, when I return back to AE2 I also get 'Unable to verify video drivers' error.

    So it would appear that my version of AE2 isn't compatible with the latest drivers.

    So can I ask where can I get the latest version of AE2 which IS compatible with my machine (no links on the website) and the latest nVidea 4** drivers, OR is your statement above incorrect?

    Thanks

  12. #12
    It should be the AE2 v5-1-181220 that works. You can download it from here.

    https://www.newtek.com/downloads/#tricaster
    Kane Peterson
    Solutions Architect
    NewTek, Inc.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •