Results 1 to 9 of 9

Thread: problems with icons

  1. #1

    problems with icons

    Click image for larger version. 

Name:	Captura de pantalla 2018-12-23 a las 2.22.56.png 
Views:	81 
Size:	132.8 KB 
ID:	143673 Modeler and Layout does not show the icons in the work windows, any idea how to solve it?

  2. #2
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,956
    It's an incompatibility between LW and macOS Mojave. There's apparently a hotfix for 2018.0.6 available (check your lightwave3d.com account page), and I believe 2018.0.7 may have the fix internally, but there's currently no fix available for versions prior to LW2018.
    John W.
    LW2015.3UB/2019.1.5 on MacPro(12C/24T/10.13.6),64GB RAM, NV 980ti

  3. #3
    Oh no! This is a big problem. I just upgraded my system to Mojave, but I still use 2015 all the time. New stuff I can build in LW2018, but for old models and scenes I still use LW2015 since that's the same old shader system and renderer they were created with. If it were just a few small icons I could live with it, but even presets don't show up.

    Is there any hope for a fix?

    Erich

    Click image for larger version. 

Name:	LW2015-Mojave.jpg 
Views:	34 
Size:	133.2 KB 
ID:	145162

  4. #4
    Tech support responded: "We are sorry that Apple broke it - we made them aware during the beta phase of Mojave, and they told us that they would not fix the issue."

    So it's off to Bootcamp and Windows 10 or a High Sierra virtual machine for when I need LW 2015.

  5. #5
    AeroAnimator 4dartist's Avatar
    Join Date
    Feb 2003
    Location
    Chattanooga, TN
    Posts
    1,071
    Has anyone with a current updated Mac know if LW 2015 still has this issue? I'm still stuck in LW 2015 for about 90% of my projects and have been using High Sierra because I can't update for fear of breaking LW. I'm curious if anyone has an updated Mac that could try LW 2015 again and just see if the icon are still broken.

    I need to start using the newer LW versions but it's a huge undertaking to update the surfacing each time a quick change to an old project pops up for the clients.

    Appreciate it if anyone had a moment to try and see.

  6. #6
    The bug still there, I have the same problem. The only way I found is, buy a new Mac Pro, with OSX Catalina, to update all my software even LW.
    And I keep my old Mac Pro 2013 and mac Book Pro 2014 with the old versions.....
    And Yes is huge undertaking to update the surfacing, and annoing work.

  7. #7
    Founding member raymondtrace's Avatar
    Join Date
    May 2003
    Location
    Ohio
    Posts
    1,148
    There are at least two more options.

    1) dual boot your Mac with old and new Mac OS systems

    2) install Windows OS via Boot Camp or as a virtual machine to run your Windows license of LightWave 2015 on your Mac hardware.
    LW4, 7.5D, 2015, 2018, 2019, 2020 running portably on a USB drive on an Amiga 2500 running Wine.

  8. #8
    AeroAnimator 4dartist's Avatar
    Join Date
    Feb 2003
    Location
    Chattanooga, TN
    Posts
    1,071
    Quote Originally Posted by raymondtrace View Post
    There are at least two more options.

    1) dual boot your Mac with old and new Mac OS systems

    2) install Windows OS via Boot Camp or as a virtual machine to run your Windows license of LightWave 2015 on your Mac hardware.
    Ok, thank you all for your replies. I've been tempted to make a transition over to Windows entirely but need to get all the use out of this Mac as I can. The dual boot with the older OS and a newer OS is an interesting option. High Sierra is starting to not support certain things, like Xcode (won't even run now) so I can't even update code on apps in the apple store and such, so at some point I have to upgrade. I'll have to look into how to do that.

    Appreciate you all letting me know that it's still broken. I never really expected a lot of support for legacy LW versions but I had some hope that this one might get attention since it disabled LW2015 for the most part. Totally understand though.

  9. #9
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,956
    Quote Originally Posted by 4dartist View Post
    High Sierra is starting to not support certain things, like Xcode (won't even run now) so I can't even update code on apps in the apple store and such, so at some point I have to upgrade.
    If you're using the proper Xcode (10.1, heard some got 10.2 working) for 10.13, then it should still run fine, mine still does. If you're trying to run the latest Xcode then it will not, because it's built for more recent versions of OS.

    Also don't forget older machines can run virtual machines with newer OS images.
    John W.
    LW2015.3UB/2019.1.5 on MacPro(12C/24T/10.13.6),64GB RAM, NV 980ti

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •