Page 1 of 2 12 LastLast
Results 1 to 15 of 21

Thread: LW 2018 .0.5 transparency not visible in viewport

  1. #1
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    200

    LW 2018 .0.5 transparency not visible in viewport

    Probably missing something but when I turn on a transparency for something like clear pipe or glass, in the viewport it vanishes completely. Normal in previous versions I still see it semi transparent. Transparancy is ticked in preferences for GL.

  2. #2
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,795
    This seems to work correctly for me in LW 2018.0.5:

    Click image for larger version. 

Name:	LW2015.0.5_GL_Transparency.jpg 
Views:	37 
Size:	1,002.3 KB 
ID:	142188

    The red sphere is a Principled BSDF material with 90% Transparency and the blue sphere is a Standard material, 50% Transparent.

    mTp

    P.S. It also works fine for me in Modeler:

    Click image for larger version. 

Name:	LW2015.0.5_Modeler_GL_Transparency.jpg 
Views:	25 
Size:	974.4 KB 
ID:	142189
    Last edited by MonroePoteet; 07-11-2018 at 10:03 AM. Reason: Add Modeler screen capture

  3. #3
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    200
    Quote Originally Posted by MonroePoteet View Post
    This seems to work correctly for me in LW 2018.0.5:

    Click image for larger version. 

Name:	LW2015.0.5_GL_Transparency.jpg 
Views:	37 
Size:	1,002.3 KB 
ID:	142188

    The red sphere is a Principled BSDF material with 90% Transparency and the blue sphere is a Standard material, 50% Transparent.

    mTp

    P.S. It also works fine for me in Modeler:

    Click image for larger version. 

Name:	LW2015.0.5_Modeler_GL_Transparency.jpg 
Views:	25 
Size:	974.4 KB 
ID:	142189
    Something weird not working. I loaded my cyber head into modeler. Looks fine so send it over to layout and it looks fine. Then soon as I move round in perspective view the pipes vanish and the chin vanishes and can no longer be viewed in viewport but can be seen in vpr.

  4. #4
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    200
    Click image for larger version. 

Name:	20180711_171802.jpg 
Views:	45 
Size:	1.87 MB 
ID:	142191Click image for larger version. 

Name:	20180711_171810.jpg 
Views:	39 
Size:	1.68 MB 
ID:	142190

    This is what happens when first sent from modeler. Soon as you move around the object in viewport the pipe's and chin vanish. If I change subpatch level then it reapers until I move view again. Never had a problem like this in previous versions of LW.

  5. #5
    Curmudgeon in Training Ma3rk's Avatar
    Join Date
    Mar 2003
    Location
    Near Beaverton, OR
    Posts
    1,434
    It's not some quirk with the Display Preferences Fixed Near Clip Distance is it? I had to turn that off but don't think I had Sub-D items.
    "Never be a cat in a cartoon. Never." Chief Wiggum

  6. #6
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    200
    Quote Originally Posted by Ma3rk View Post
    It's not some quirk with the Display Preferences Fixed Near Clip Distance is it? I had to turn that off but don't think I had Sub-D items.
    Nope that's off. Just updated my graphics driver and still no change. No idea what's going on. Only thing I can think off is this was created in LW 11.6.3 and 2018 converted it. So maybe it's a problem linked to that.

  7. #7
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,795
    Yes, definitely a bug in viewport rendering in LW2018.0.5. Attached is a reproducer scene.

    Interestingly enough, if ALL surfaces are somewhat transparent, they all show up. If ANY surface has a 0.0% Transparency, then surfaces with non-zero transparency disappear.

    In the sample scene, all three surfaces have non-zero Transparency, and the Perspective viewport can be rotated with all surfaces visible. Changing any of the surfaces to have 0.0% Transparency causes the non-zero transparency surfaces to vanish in the viewport.

    The easy way to recover their visibility (temporarily) is to use the Modeler Tools=>Toggle Subpatch button, which refreshes the viewport with all surfaces showing. The problem persists whether subpatches are on or off.

    Setting the 0.0% Transparency surface back to non-zero, refreshing with Toggle Subpatch causes them all to appear again even after the viewport is updated. Here's the sequence, using ALT-right-mouse-drag in the viewport to rotate it for each test:

    Click image for larger version. 

Name:	TransparencyViewportBug_AllNonZero.jpg 
Views:	20 
Size:	972.1 KB 
ID:	142192 All Surfaces non-zero Transparency, even after rotating viewport
    Click image for larger version. 

Name:	TransparencyViewportBug_BlueZero_BeforeRotate.jpg 
Views:	19 
Size:	873.0 KB 
ID:	142193 Set BluePatch to 0.0% Transparency, before rotating viewport
    Click image for larger version. 

Name:	TransparencyViewportBug_BlueZero_AfterRotate.jpg 
Views:	17 
Size:	909.1 KB 
ID:	142194 After rotating viewport
    Click image for larger version. 

Name:	TransparencyViewportBug_BlueZero_ToggleSubpatch.jpg 
Views:	16 
Size:	958.5 KB 
ID:	142195 After pressing Toggle Subpatch
    Click image for larger version. 

Name:	TransparencyViewportBug_BlueFifty_BeforeToggleSubpatch.jpg 
Views:	13 
Size:	905.4 KB 
ID:	142197 Set BluePatch back to 50.0%, before Toggle Subpatch
    Click image for larger version. 

Name:	TransparencyViewportBug_BlueFifty_AfterToggleSubpatchAndRotate.jpg 
Views:	15 
Size:	975.1 KB 
ID:	142198 All Surfaces non-zero again, after Toggle Subpatch and rotating viewport

    Do you want to submit a Bug Report, or shall I?

    mTp
    Attached Files Attached Files

  8. #8
    Quote Originally Posted by genesis1 View Post
    Nope that's off. Just updated my graphics driver and still no change. No idea what's going on. Only thing I can think off is this was created in LW 11.6.3 and 2018 converted it. So maybe it's a problem linked to that.
    Was your object originally a .OBJ? I have come across an issue in the past when an .OBJ is brought into LW, the default surface is not named correctly. In Modeler, hit 'q' and just give it a new default surface and then save it. See if it now works in Layout.

  9. #9
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,795
    Axis3D and I cross posted - it's a bug. See my prior post:

    https://forums.newtek.com/showthread...=1#post1550551

    The object used in the test was created from scratch in LW2018.0.5 Modeler and surfaced natively.

    mTp

  10. #10
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    200
    Quote Originally Posted by MonroePoteet View Post
    Yes, definitely a bug in viewport rendering in LW2018.0.5. Attached is a reproducer scene.

    Interestingly enough, if ALL surfaces are somewhat transparent, they all show up. If ANY surface has a 0.0% Transparency, then surfaces with non-zero transparency disappear.

    In the sample scene, all three surfaces have non-zero Transparency, and the Perspective viewport can be rotated with all surfaces visible. Changing any of the surfaces to have 0.0% Transparency causes the non-zero transparency surfaces to vanish in the viewport.

    The easy way to recover their visibility (temporarily) is to use the Modeler Tools=>Toggle Subpatch button, which refreshes the viewport with all surfaces showing. The problem persists whether subpatches are on or off.

    Setting the 0.0% Transparency surface back to non-zero, refreshing with Toggle Subpatch causes them all to appear again even after the viewport is updated. Here's the sequence, using ALT-right-mouse-drag in the viewport to rotate it for each test:

    Click image for larger version. 

Name:	TransparencyViewportBug_AllNonZero.jpg 
Views:	20 
Size:	972.1 KB 
ID:	142192 All Surfaces non-zero Transparency, even after rotating viewport
    Click image for larger version. 

Name:	TransparencyViewportBug_BlueZero_BeforeRotate.jpg 
Views:	19 
Size:	873.0 KB 
ID:	142193 Set BluePatch to 0.0% Transparency, before rotating viewport
    Click image for larger version. 

Name:	TransparencyViewportBug_BlueZero_AfterRotate.jpg 
Views:	17 
Size:	909.1 KB 
ID:	142194 After rotating viewport
    Click image for larger version. 

Name:	TransparencyViewportBug_BlueZero_ToggleSubpatch.jpg 
Views:	16 
Size:	958.5 KB 
ID:	142195 After pressing Toggle Subpatch
    Click image for larger version. 

Name:	TransparencyViewportBug_BlueFifty_BeforeToggleSubpatch.jpg 
Views:	13 
Size:	905.4 KB 
ID:	142197 Set BluePatch back to 50.0%, before Toggle Subpatch
    Click image for larger version. 

Name:	TransparencyViewportBug_BlueFifty_AfterToggleSubpatchAndRotate.jpg 
Views:	15 
Size:	975.1 KB 
ID:	142198 All Surfaces non-zero again, after Toggle Subpatch and rotating viewport

    Do you want to submit a Bug Report, or shall I?

    mTp
    I'll let you send the bug report. Glad I'm not the only one. Thought I was going crazy! ��

  11. #11
    Quote Originally Posted by genesis1 View Post
    I'll let you send the bug report. Glad I'm not the only one. Thought I was going crazy! ��
    Definitely related to sub-patching. Not crazy.

  12. #12
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,795
    Bug report submitted.

    mTp

  13. #13
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    200
    Thanks. Yes you are right. I can reproduce exactly the same result.

  14. #14
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,795
    Here's the response from LWDG, which does indeed resolve the issue on the sample scene.

    Click image for larger version. 

Name:	ChangeGeometryAccelerationToStreaming.jpg 
Views:	26 
Size:	1,007.8 KB 
ID:	142200

    mTp

    ------------------------------------------------------------------------------------------

    From: Deuce
    Date: July 11, 2018, 10:59 a.m.
    This is where the "complexity of the scene" can't be totally handled by Buffered Geometry Acceleration.

    If you change to "streaming" - all works as you'd expect.

    Thank you for your report.
    --
    LightWave 3D Group Support

    [email protected]

  15. #15
    Registered User
    Join Date
    Aug 2006
    Location
    UK
    Posts
    200
    Quote Originally Posted by MonroePoteet View Post
    Here's the response from LWDG, which does indeed resolve the issue on the sample scene.

    Click image for larger version. 

Name:	ChangeGeometryAccelerationToStreaming.jpg 
Views:	26 
Size:	1,007.8 KB 
ID:	142200

    mTp


    ------------------------------------------------------------------------------------------

    From: Deuce
    Date: July 11, 2018, 10:59 a.m.
    This is where the "complexity of the scene" can't be totally handled by Buffered Geometry Acceleration.

    If you change to "streaming" - all works as you'd expect.

    Thank you for your report.
    --
    LightWave 3D Group Support

    [email protected]
    Thanks for posting. Will change to streaming. However ,your example scene isn't complex so don't know why LW2018 can't handle it when 11.6.3 can manage it. Tbh I'm not finding anything benefiting me in 2018 yet except a more stable fiber fx. 😞

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •