Results 1 to 5 of 5

Thread: Particle problem - 2015.3

  1. #1

    Particle problem - 2015.3

    Hi,
    I found an old post about the same problem, of year 2007, so after more than 10 years I open now this new thread, maybe something is changed.

    I must simulate a water pipe. The water go out fast. I no need the fluid dynamic simulation, normal particles are enough. The problem is that lw doesn't calculate the subframes, so the particles are emitted as "cluster", one group of particle every frame. The water doesn't do a good flow.
    I tried to change the scene at 200 fps, all is good at this speed, the flow is wonderful, so I save the pfx file, open again my scene at 25fps, load the file motion in the emitter, set the playback speed at 800% and.... nothing... again lw emits groups of particle every frame. It seems that it read the pfx file only every frame and makes a mess. So I turned on the fractional frames in the preferences panel, to see what happens between one frame and the next. Happens nothing! The particles are emitted when the frame changes, at xx.00. Nothing from xx.01 to xx.99. damn! It is a pfx file 200fps, why happens nothing between one frame and the next? There must be 8 "subframes". Nothing, these 8 subrames are joined as all 8 start in the same time.
    This is really a big problem because I can't do my work.
    Ay idea?

    Ah, of course I could render my video at 200 fps, step 8... or, more simple, set fps 250 and render step 10. But it is a mess.

    Thank you for help.

  2. #2
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,792
    My first suggestion is to avoid the Calculate button for Emitters at all costs. If you make a change to your Emitter settings, instead of pressing the "Calculate" button to recreate the particles, set the timeline to Frame 0 and play the timeline. For whatever reason, Calculate produces clusters of particles as you describe rather than a good distribution.

    Other than that, you might post a screen shot of the Emitter settings. Other suggestions are use Per Second rather than Per Frame, clear the "Fixed Random" flag, increase the dimensions of the emitter in the direction of the particle flow, put some Vibration on them.

    I've attached a very quick scene similar to what you describe. As mentioned, if you press Calculate to simulate the particles you'll get globs, whereas making a change to the Emitter (I usually just re-select Per Second), set frame to 0 and press play (or use right-arrow) will generate a continuous flow.

    Click image for larger version. 

Name:	Particles_HV_waterFromAPipe_FastWater_0006.jpg 
Views:	26 
Size:	192.8 KB 
ID:	141407

    mTp
    Attached Files Attached Files

  3. #3
    Thank you for the answer. Already I tried all what you said, nothing changed. Usually I don't use the Calculate button, only when there are the collisions I use it, but not this time. I can't increase the size because the pipe moves, so the emitter must be only on the tip. Per second or oer frame change nothing (of course must set the birth rate per frame 1/25 than per second). Fixed or not fixed change nothing.
    I made another scene with a big emitter, seems it is more good. But for this work I need a little emitter. Size is 0,015. Resize it in Scale mode or set the generator size, in the particle panel, gives the same mess.
    Click image for larger version. 

Name:	Part.JPG 
Views:	26 
Size:	89.1 KB 
ID:	141409
    The pipe moves down, more fast than the particle falls.

  4. #4
    Electron wrangler jwiede's Avatar
    Join Date
    Aug 2007
    Location
    San Jose, CA
    Posts
    6,485
    @Wilfrick: Just a guess, but... In Layout, under "Edit->General Options" (key: o), about midway down the panel, are "fractional frames" enabled?
    John W.
    LW2015.3UB/2018.0.7 on MacPro(12C/24T/10.13.6),32GB RAM, NV 980ti

  5. #5
    Registered User
    Join Date
    Jan 2005
    Location
    Colorado Springs
    Posts
    1,792
    Is your Position Blur set less than 100% in the etc tab? I can reproduce the "puffs" of particles if I set it to zero. Otherwise, the particles are generated continuously between frames even at the 2500 particles / second in your screen capture.

    Also, what is the purpose of the really high particle count? If you're going to use HyperVoxels to give the particles shape and surface characteristics, you may be able get away with substantially fewer particles and use the Additive blending mode in HV's to combine them into a stream. If you look at the details of the scene I posted previously, the particle count is fairly small and HV stretching in Velocity and Additive blending is used to create the stream.

    Otherwise, you may have to post your scene (or a sample scene) for analysis.


    mTp

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •