Results 1 to 2 of 2

Thread: Spped up Rendering Times

  1. #1
    Super Member
    Join Date
    Mar 2008
    Prince Edward Island

    Spped up Rendering Times

    Hi all. I am now using 2018 and slowly learning the new features.
    Would anyone have a list of things to check that would cause slow render times?
    I am outputting for print at 4000px wide x 3000pixels tall.

  2. #2
    Registered User OjN's Avatar
    Join Date
    Mar 2014
    Grand Rapids, Mi


    In short... a recollection of comments about it. I recommend read the Arnold help...

    The tile render size have an impact on render times. Divide my resolution by the tile size. If the result is equal or greater than the number of threads, I use that size. Otherwise, I move down to the next smaller size. (Eg : I'm rendering @ 960 x 540; I have an I7 960, so I have 8 threads. Thisd gives me 6 tiles @ 256 x 256 (960 / 256 = 3, rounded down, 540 / 256 = 2, rounded down, for 6 tiles) I set my tile size for 128 x 128. The idea behind this is to have as much of the image being rendered as possible at any given time for the first pass. The second pass can split up tiles between cores.

    Render a smaller image and scale it 133% (softer&faster)

    First, reduce your camera samples to the minimum checking the alpha buffer, the beauty buffer, DOF and Blur buffers to fix anti-lasing. I would start by bringing up Min samples, once the issue goes away, start backing down on max samples. Higher camera samples (number of rays per pixel that will be traced from the camera) increases anti-aliasing quality, but it increases the sampling rate for everything and the render times. camera to 4 minimum samples Note that this process is the square of the input value. For example, if Camera samples is 3, it means that 3x3 = 9 samples will be used for anti-aliasing. If Diffuse samples is 2, then 2x2 = 4 samples will be used for the Diffuse GI. Anti-Aliasing need to be increased in 2018 to match lw2015. camera's min and max samples. changed AA to 8 - 16, changed GI to 50% and got this in 2 min 41 sec. Mipmapping on by default for better results. anti-aliasing to a threshold of 0.094, the noise reduction workflow always samples(Light, Reflection, Refraction, SSS) before AA passes. Try to keep your samples and AA passes as low as possible. The exception to this is things with a high frequency texture (like a woven mat) or FiberFX - then you will need more AA passes... about double. Adaptive AA, if set right, can save you a bit of time. Try a value of between .05 - .1 instead of the default to start with. Otherwise, leave it unchecked.

    Identify the source of noise and increase the sampling values of those specific rays. It is always a good idea to kick out a frame with all of the standard buffers enabled and see what pass they are on. Later, use VPR buffers and to turn on/off features (isolate lights and surfaces properties). Just track down which light has the sample problem using the individual buffer view/ If the noise disappears whe Set Diffuse Samples to 0 then it is created by indirect diffuse. If the noise disappears when Set Refraction samples to 0 (remove blurred refractions) then it is created by glossy refractions. Alternatively set Diffuse samples and Specular samples to 0 which will remove GI which will allow you to single out the direct lighting contribution. Alternatively set Diffuse samples and Specular samples to 0 which will remove GI which will allow you to single out the direct lighting contribution.

    Adjust lights and emitters first because render time will double for each Diffuse sample when attempting to optimize the number of indirect diffuse ray. use environment lights for exteriors, dont bother with BG radiosity, portals for interiors. Check your noise in specular highlights. Indirect specular noise occurs when the Specular Roughness parameter > 0. Increasing the Specular Roughness value and thehe size of the light and reducing its intensity can also help in these situations. Noise in soft shadows from large area lights. lights with large radii mixed up with indirect diffuse noise particularly for because their shadows will be softer.Try to turn off shadows or disabling 'Diffuse' rays (0) to identify which type of noise is present because noise by large area lights can be mistaken for indirect diffuse noise. In some cases, set to 16 to 24 Reflections samples. Upping MIS sample size (this determines how many pixels are in the image that is being sampled for the reflection) of the Environment Light Properties Panel to 512, or 1024 or even 2048. Environment lights require about double samples than other lights... Don’t put lights too close to the windows. If a light is too close to the window, that means the light hitting the window area is significantly more concentrated and so much brighter than the light hitting the far side of the room and so this produces more noticeable noise. you'd have pixelated reflections when your MIS resolution is too low in your lights. Check the same setting in the GI tab. The MIS should be equal to the backdrop image resolution. For rougher surfaces you can reduce the resolution of your MIS accordingly. we need a nodal HDR limit. Eliminate Fireflies/sparkles in atmosphere, Using area lights with volume scattering can generate bright 'spike' type noise. The problem is in areas of the volume that are very close to the light source's area (a disk in this case). You can avoid this problem by using a point_light or spot_light with radius 0. That makes the sampling a lot easier as there is no area to sample.

    Adjust reflection Samples checking specular indirect buffer. Limit your specular rays from 6 to 3. You can check by setting the surface in which something is reflected to have a Roughness of 0. If the noise disappears you know there is a problem in Specular Indirect. Try adding a little roughness to your specular objects, and enable clamping in the render globals. Crank up 6 samples or more for refraction and reflexion if I have reflective materials. Arnold. There are several ways to fix the noise around the eyes: Make the eyes invisible to glossy rays. This can be done by disabling the glossy flag in the object's visibility bitmask. Here is the animation re-rendered with this fix: One possible solution is to limit, or clamp, the maximum Phong exponent to a low value such as 20 or 50, but only for secondary reflections. This is equivalent to the ray_switch solution mentioned before. As shown in the image below, this works quite well in practice. If all else fails, you'll have to use the rayswitch shader. There is a great tutorial on SolidAngle's website, and is too complicated for me to explain here.

    Adjust your diffuse samples checking diffuse and indirect buffer. Adjust your GI using simple raytrace or with Interpolated gi, no all case need use Montecarlo with bsdf surface. GI and are prone to creating fireflies. Use brute force only for exterior renders. Interior with interpolated Montecarlo with "Interpolation Softness" set to 100%. Another method to reduce noise is to remove the cause and fake it with special lights. For example a character whose face is lit by bounce light only: it will be much less noisy to add a specific bounce light.
    Last edited by OjN; 04-13-2018 at 05:02 PM. Reason: to long..


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts