Results 1 to 3 of 3

Thread: Connect Spark & exFAT Micro sd cards or Thumb Drives? NTFS?

  1. #1
    Registered User
    Join Date
    Jun 2013
    Los Angeles

    Connect Spark & exFAT Micro sd cards or Thumb Drives? NTFS?

    I just purchased a Connect Spark. Updated the firmware yesterday. It's hardware version 1.6.15 and firmware version 3.82.0483

    Tried recording on both a micro sd card and a thumb drive formatted as FAT32. Works ok.

    Then I formatted both to exFAT to avoid the 4gb file size limit on FAT32. The Spark would not recognize either as exFAT.

    So I am left to believe exFAT is currently not supported for the Connect Spark?

    I have 2 questions:

    1. Will Newtek be updating the firmware to allow exFAT drives (micro sd cards or thumb drives)?

    2. When recording in FAT32, will it continue to record once the 4gb limit is reached and begin another recording to another file leaving the first intact? So if I had a show that went on for 3 hours, i would have several files on the card?

    I did record to a thumb drive formatted as NTFS successfully, however I prefer exFAT for compatibility between windows and mac.


  2. #2
    Registered User
    Join Date
    Aug 2011
    Richmond, VA
    IMO, portable media should never be anything other than exFAT. It's so completely unnecessary to ever be handed a flash drive you can't read! We were baffles that most of our drives wouldn't work with Spark. Didn't occur to me that it wouldn't support exFAT, so count me in on that feature request.
    E. Lee Dickinson | President
    Advanced Visual Production |

    Tricaster 850, 460AE, and TC-1
    JVC GY-HM200u, Canon XLH1, Fieldcast and BMD Fiber

  3. #3
    Registered User
    Join Date
    Mar 2019
    Quote Originally Posted by Lee-AVP View Post
    IMO, portable media should never be anything other than exFAT.
    For SD cards, the partition type is part of the specifications - SD is Fat16, SD-HC is Fat32, and SD-XC is ExFat.
    The vast majority of products follow these specifications, so it's a suprise that I've seen two devices used in streaming that don't - one being the Spark, the other being the Netgear M1 (4G router)

    In a similar vein, has anyone had an issue with a Spark not seeing that an SD card is inserted?
    I have two sitting here with the 1911 firmware installed, that don't see an SD card at all - I've tried various 16, 32 and 64Gb cards, in Fat32 and ExFat.
    They record normally to a USB stick.
    Last edited by PiD Media; 03-13-2019 at 04:26 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts