Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: Did I miss something here, still no textures in opengl,t all things go nodal in surfa

  1. #1
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    17,030

    Did I miss something here, still no textures in opengl,t all things go nodal in surfa

    well..we got these new shaders etc, but what on earth is going on with the issues of lightwave not being able to display nodal image map textures ...to be allowed to be displayed in opengl?
    If that is the case, very annoying.

  2. #2
    Super Member Snosrap's Avatar
    Join Date
    Aug 2004
    Location
    Ohio, USA
    Posts
    4,925
    They work for me.

  3. #3
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    8,227
    Sometimes they do work, sometimes they don't work.

    Click image for larger version. 

Name:	OpenGL texture.png 
Views:	153 
Size:	753.0 KB 
ID:	139845

  4. #4
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    17,030
    Quote Originally Posted by Sensei View Post
    Sometimes they do work, sometimes they don't work.

    Click image for larger version. 

Name:	OpenGL texture.png 
Views:	153 
Size:	753.0 KB 
ID:	139845
    Well..that is the standard material, inside of nodes...so that is no surprise, we do however need textures when using the new skin or principled shaders, and some others.

    - - - Updated - - -

    Quote Originally Posted by Snosrap View Post
    They work for me.
    as in the above answer, and not with the new skin material etc?
    Edit...sorry, it works with prinicpled BSDF, but what was really important was the new skin material.

  5. #5
    Registered User
    Join Date
    Apr 2016
    Location
    Barcelona, Spain
    Posts
    585
    Radeon?
    English is not my native language so please be patient.

    Salvador Ureņa
    http://urenasalvador.wixsite.com/portfolio

  6. #6
    Grumpy Faux-Waver DogBoy's Avatar
    Join Date
    Feb 2003
    Location
    Central London
    Posts
    1,549
    Skin is one of the few that doesn't. I think it has to do with the amount of colour inputs that have to be mixed.
    fauxWaver \foʊ-wāv-er\, n. one who likes LightWave, but shuns car-anologies.

  7. #7

  8. #8
    Registered User
    Join Date
    Aug 2016
    Location
    a place
    Posts
    2,470
    Quote Originally Posted by prometheus View Post
    Well..that is the standard material, inside of nodes...so that is no surprise, we do however need textures when using the new skin or principled shaders, and some others.
    why is that no surprise? the standard material should work and display textures. if it doesn't then its a problem and a bug.

  9. #9
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    17,030
    Quote Originally Posted by gar26lw View Post
    why is that no surprise? the standard material should work and display textures. if it doesn't then its a problem and a bug.
    I never said standard material doesn't work.
    Standard material has always worked.
    Outside of nodes. ..so a standard material inside of nodes is hardly a surprise that it works.

    As mentioned. .skin is the one not working...While principle does. ..I was to hasty on that one.

    I should have been more clear...and mention not just texturing in nodes alone...but various materials.

  10. #10
    Grumpy Faux-Waver DogBoy's Avatar
    Join Date
    Feb 2003
    Location
    Central London
    Posts
    1,549
    Quote Originally Posted by prometheus View Post

    As mentioned. .skin is the one not working...
    So, to be clear. It isn't nodes in general being unable to display, it's just Skin and Image/Normal Samplers.
    As I said, I suspect for the former it's the mixing of colour inputs. The latter is more of an issue IMO, as it makes working with them a bit of a pain. I've FRed both of these a month ago, so let's hope 2018.1 sees a fix.
    fauxWaver \foʊ-wāv-er\, n. one who likes LightWave, but shuns car-anologies.

  11. #11
    Registered User
    Join Date
    Aug 2016
    Location
    a place
    Posts
    2,470
    Quote Originally Posted by prometheus View Post
    .so a standard material inside of nodes is hardly a surprise that it works.

    As mentioned. .skin is the one not working...While principle does. ..I was to hasty on that one.

    I should have been more clear...and mention not just texturing in nodes alone...but various materials.
    oh i see, nah i think i just misunderstood. my mistake but it sure would be nice if it did work

  12. #12
    Plays with fire sadkkf's Avatar
    Join Date
    Feb 2003
    Location
    Outside looking in
    Posts
    1,236
    Quote Originally Posted by Asticles View Post
    Radeon?
    It works with my Radeon.
    So much water, so few sharks.

    "...all men are created equal." -- US Declaration of Independence

  13. #13
    Registered User
    Join Date
    Aug 2016
    Location
    a place
    Posts
    2,470
    Quote Originally Posted by DogBoy View Post
    So, to be clear. It isn't nodes in general being unable to display, it's just Skin and Image/Normal Samplers.
    As I said, I suspect for the former it's the mixing of colour inputs. The latter is more of an issue IMO, as it makes working with them a bit of a pain. I've FRed both of these a month ago, so let's hope 2018.1 sees a fix.
    thankyou

  14. #14
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    17,030
    Quote Originally Posted by sadkkf View Post
    It works with my Radeon.
    what works with Radeon? the new skin modifier? (not the old)
    or if you mean principled BSDF and standard material? those work here.so that is of no difference VS nvidia GTX

  15. #15
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    17,030
    Quote Originally Posted by DogBoy View Post
    So, to be clear. It isn't nodes in general being unable to display, it's just Skin and Image/Normal Samplers.
    As I said, I suspect for the former it's the mixing of colour inputs. The latter is more of an issue IMO, as it makes working with them a bit of a pain. I've FRed both of these a month ago, so let's hope 2018.1 sees a fix.
    I think I went on rampage prematurely when I tried the new skin material and nodes, with reference to that nodes in general in 2015, Was not capable of showing textures if it ran through the nodes as I am aware of, so a simple image map, fed directly to color input in the old surface node, it wouldnīt show that image texture in the openGL, so after the initial new skin test and not seeing the textures, I assumed wrong in that it would be the same for 2018, but as proven..that has changed, except for the new skin material that is.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •