Results 1 to 5 of 5

Thread: IKFK Blending issue with targeted items

  1. #1

    IKFK Blending issue with targeted items

    Hello Guys,
    So I have finally bumped into this issue most of you probably have bumped too.

    Namingly:
    I have this arm rig. Shoulder - Upperarm - Lowerarm - Wrist

    Wrist is controlled by a Null named "IK_Controller"
    Upperarm is IK driven
    Lowerarm is IK driven too.
    Shoulder is targeted to the null "IK_Controller" to establish a 2D plane in which the Upper and Lower arm can exist exclusively (otherwise the controller strays away)

    BUT! When I switch to FK the Targeting from Shoulder to Wrist remains intact so I can't achieve a fully independent FK rotational solution. Whenever I move the target
    it affects the Arm bones.

    Is there any workaround for this or do I have to build my own IKFK blending system?
    Thanks

  2. #2
    Super Member Kryslin's Avatar
    Join Date
    Feb 2009
    Location
    Prescott, IA
    Posts
    1,472
    It would help if we could see an actual example of what you're trying to do.

    That being said, you will have to build separate FK and IK Controls, and set up blending between the IK -> FK controls, and drive the bones/joints with the FK Control items.

    FK/IK Blending on the motion options panel tends to turn off FK/IK blending globally, and do some other, undesirable things as well.

    I'm sure RH will be along to say pretty much the same thing, and add links to one of his training videos - which may be on youtube -will explain it a lot better than I can.
    Like this one : FK and IK Basics
    Or maybe this : Inverse Kinematics
    --------
    My Scripts for Lightwave
    Intel Core i7 960 @3.20 Ghz, 24 GB ram, EVGA 6GB GTX980Ti "Classified" driving 2 x HP LA2405.

  3. #3
    Quote Originally Posted by Kryslin View Post
    It would help if we could see an actual example of what you're trying to do.

    That being said, you will have to build separate FK and IK Controls, and set up blending between the IK -> FK controls, and drive the bones/joints with the FK Control items.

    FK/IK Blending on the motion options panel tends to turn off FK/IK blending globally, and do some other, undesirable things as well.

    I'm sure RH will be along to say pretty much the same thing, and add links to one of his training videos - which may be on youtube -will explain it a lot better than I can.
    Like this one : FK and IK Basics
    Or maybe this : Inverse Kinematics
    Thanks Kryslin.
    Images here: Yellow bone is shoulder, it is targeted at the IK controller (white sphere) . Red bone is the end of the IK chain.
    Click image for larger version. 

Name:	IKFKblendingIssue.JPG 
Views:	120 
Size:	91.5 KB 
ID:	136048Click image for larger version. 

Name:	IKFKblendingIssue2.JPG 
Views:	123 
Size:	53.6 KB 
ID:	136049
    On the second image from the left we see that the IK has been disabled on the wrist/red bone so the arm bones can be rotated freely but still the white sphere
    affects them. So you say there is no way to deactivate runtime this target. What a pity! Cheers and thanks again.

  4. #4
    Goes bump in the night RebelHill's Avatar
    Join Date
    Nov 2003
    Location
    jersey
    Posts
    5,766
    Depends which version of LW you're using.

    If pre-11.6 (or maybe 11.something, cant remember exactly when the change was made), there's nothing you can do... only option is to build separate chains for FK and IK which cross constrain. Otherwise, the trick is to turn on Unaffected by IK of Descedents NOT for the targeting (plane) item, but for its parent.
    LSR Surface and Rendering Tuts.
    RHiggit Rigging and Animation Tools
    RHA Animation Tutorials
    RHR Rigging Tutorials
    RHN Nodal Tutorials
    YT Vids Tuts for all

  5. #5
    Quote Originally Posted by RebelHill View Post
    Depends which version of LW you're using.

    If pre-11.6 (or maybe 11.something, cant remember exactly when the change was made), there's nothing you can do... only option is to build separate chains for FK and IK which cross constrain. Otherwise, the trick is to turn on Unaffected by IK of Descedents NOT for the targeting (plane) item, but for its parent.
    Cool, it works. Big thanks Rebel!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •