Results 1 to 5 of 5

Thread: NDI COnnect Pro, Telestrator and a Blackmagic Quad card

  1. #1

    NDI COnnect Pro, Telestrator and a Blackmagic Quad card

    Hello awesome forum,

    Trying to wrap my head around what may be going on. I have a couple of components here:

    1 - An NDI Connect Pro computer with two Decklink Quad cards installed. 7 of these are outputs and 1 is an input. The reason we have 2 cards is that this is normally a CasparCG system and we're just playing with NDI Connect Pro.
    2 - I have a Windows 10 touchscreen system with the NDI Telestrator software

    OK, so what I want to do is take one of the outputs from our switcher and convert it to NDI for our telestrator background. Easy, done. Works.

    Next I want to take the NDI output of the Telestrator and send it back to NDI Connect Pro to convert that back to SDI. This is where I run in to problems:
    - We can sometimes get the NDI to convert back to SDI, but only in SD-SDI
    - As soon as we select 1080p/29 as my output resolution, the system no longer outputs any video and NDI stops updating on the screen
    - Restarting NDI Connect Pro won't save the resolution settings, so it always reverts to SD-SDI
    - When in SD-SDI mode the image is 4:3 so even if I just pass it through a scaler, I'm either cutting off the corners or stretching the image so it is all borked up on output
    - I can't seem to find a way to break the Telestrator output in to its individual key and fill signals when converting NDI to SDI

    Thoughts? Is this just a Decklink driver issue? Am I trying to make one box do too much? Something else simple that I'm missing?

  2. #2
    Registered User
    Join Date
    Oct 2016
    Location
    Norway
    Posts
    1
    Bump, having the same issue.

    By the way, local NDI sources does not appear, only NDI sources from other pcs, is this normal???

  3. #3
    I would make sure you aren't using the 10.8.1 Decklink drivers, we saw severe output problems with those. They were quickly replaced by 10.8.2 which seemed much better.

    I see that there is now a 10.8.3 driver available but I have not personally tested those yet.

    You should get the output resolution you select, not SD even if the input source is SD. That is assuming that all pieces if the system working together correctly, such as working drivers and that there is no new bug on our side.
    John Perkins
    Software Engineer

    "No, it's my natural color..."

  4. #4
    Registered User zenvideo.co.uk's Avatar
    Join Date
    Apr 2016
    Location
    Salford, UK
    Posts
    28
    Quote Originally Posted by haavardnj View Post
    By the way, local NDI sources does not appear, only NDI sources from other pcs, is this normal???
    There is a variable when creating the "NDI finder" which determines this behaviour (show_local_sources = TRUE/FALSE). Presumably this is set to FALSE, but maybe it could be made an option in the settings (if enough people ask for it)?
    Martin Kay
    ZEN Computer Services - Salford, UK

  5. #5
    Quote Originally Posted by haavardnj View Post
    By the way, local NDI sources does not appear, only NDI sources from other pcs, is this normal???
    Yes, this is expected so that you don't have to see your own NDI outputs when selecting inputs.

    There is currently no way to change this, but I can see a potential use case if multiple applications are running on the same system.
    John Perkins
    Software Engineer

    "No, it's my natural color..."

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •