Results 1 to 7 of 7

Thread: Still problems with 3D Coat normal maps and LW 2015?

  1. #1
    Spinny Spinland's Avatar
    Join Date
    Apr 2005
    Location
    Utica NY, USA
    Posts
    2,014

    Still problems with 3D Coat normal maps and LW 2015?

    I seem to be having the same issues that I'm seeing talked about from years ago. I UV mapped and textured a LW mesh inside of 3D Coat and when I open the new LWO file in Layout the normal maps show ugly seams. If I disable nodes on the textures in question the problems go away but I'm left with no texture displacement. Here are two renders of the same model, the second with nodes turned off.

    Click image for larger version. 

Name:	bad_normals.png 
Views:	45 
Size:	336.9 KB 
ID:	132601 Click image for larger version. 

Name:	no_normals.png 
Views:	45 
Size:	341.5 KB 
ID:	132600

    I've tried various normals presets in the 3DC preferences panel but with no idea what I'm doing I'm flying blind. Are there settings in 3DC 4.5 that will fix this problem in LW 2015? If not, does anyone know of a workaround?

    Many thanks in advance!
    “There may be people that have more talent than you, but there’s no excuse for anyone to work harder than you do.” ~ Derek Jeter

    iMac Pro
    "iCan" Mac Pro
    MacBook Pro
    Multiple Mac Minis

  2. #2
    Spinny Spinland's Avatar
    Join Date
    Apr 2005
    Location
    Utica NY, USA
    Posts
    2,014
    For whatever it's worth, for now I've just abandoned trying to use the normal map channel. The nodal editor gives me a ton of options for just using the nmap textures via the bump channel and I've added several scalar tweak nodes to give me a lot of control. Working fine and no ugly seams.
    “There may be people that have more talent than you, but there’s no excuse for anyone to work harder than you do.” ~ Derek Jeter

    iMac Pro
    "iCan" Mac Pro
    MacBook Pro
    Multiple Mac Minis

  3. #3
    When you bring a normal map into Layout you must change it's color space to linear in the image editor. Did you do this?

  4. #4
    Spinny Spinland's Avatar
    Join Date
    Apr 2005
    Location
    Utica NY, USA
    Posts
    2,014
    Wow. And just like that problem solved. THANK YOU!

    I do so much reading and watching of training videos in my down time, but there's so much knowledge out there I do miss embarrassingly obvious things at times.

    Fortunately the LW community rocks hard core. Thanks again!
    “There may be people that have more talent than you, but there’s no excuse for anyone to work harder than you do.” ~ Derek Jeter

    iMac Pro
    "iCan" Mac Pro
    MacBook Pro
    Multiple Mac Minis

  5. #5
    I wouldn't call it embarrassingly obvious. I was using normal maps for a while before I realized they needed to be converted to linear.

  6. #6
    Spinny Spinland's Avatar
    Join Date
    Apr 2005
    Location
    Utica NY, USA
    Posts
    2,014
    Thanks for that. I allow I have a problem with being too hard on myself at times.
    “There may be people that have more talent than you, but there’s no excuse for anyone to work harder than you do.” ~ Derek Jeter

    iMac Pro
    "iCan" Mac Pro
    MacBook Pro
    Multiple Mac Minis

  7. #7
    Curmudgeon in Training Ma3rk's Avatar
    Join Date
    Mar 2003
    Location
    Near Beaverton, OR
    Posts
    1,345
    Quote Originally Posted by djwaterman View Post
    When you bring a normal map into Layout you must change it's color space to linear in the image editor. Did you do this?
    Well, that's good to know.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •