Results 1 to 8 of 8

Thread: Windows 10 (register problems)

  1. #1
    Registered User
    Join Date
    Jul 2012
    Location
    Wallingford, CT
    Posts
    32

    Windows 10 (register problems)

    Today, I came into work to find out Speed Edit 2.0 had un-registered its self, and I needed to contact support via chat (I love the support chat service by the way) to get Speed edit regestered again. I was told that this is sometimes due to a windows update. I updated another computer later and found out that that computer now needed to have Speed Edit reregestered.

    This is rather frusterating! I do not want to wast my time re-registering Speed Edit every other week just because I want to keep my computers up to date. Is there any suggestion as to how this can be avoided?

    Thanks,

    Alan Billings

  2. #2
    Although it is still considered unsupported, we created a patch that should allow the latest SpeedEDIT 2 to activate on Windows 10.

    It is mostly intended for Windows 10 users, but could be useful to others who are running with limited user permissions.

    It is of no use with the TriCaster Add-On version of SE2 as it registers in a completely different way, to the TriCaster itself.

    If you aren't having the issue, then there is no point in installing it. It only fixes this one issue, it's otherwise identical.

    You will need to install SE2 prior to running the patch.

    It will be on the website sometime next week, but until then, please contact tech support for instructions on how to receive it.
    John Perkins
    Software Engineer

    "No, it's my natural color..."

  3. #3
    John

    Where is the patch for Windows 10 and how can we get it?

  4. #4
    VT[2] Aficionado
    Join Date
    Jan 2005
    Location
    Seattle
    Posts
    188
    John, the newest version I see on the site is 2.6.2 from 2014. Any chance the patch is buried on the FTP site somewhere or could be posted to http://newtek.com/downloads/previous.html? I've run into issues even on Windows 7 running as a limited user, like SpeedEDIT claiming my activation key was invalid until I ran it elevated. I also had no idea there was even a patch until I started digging around here. The support agent I spoke with during my activation troubles made no mention of this patch. Thanks for any help/insight you could offer!
    Last edited by Kevin Brice; 12-08-2016 at 03:13 AM.

  5. #5
    VT[2] Aficionado
    Join Date
    Jan 2005
    Location
    Seattle
    Posts
    188
    Quote Originally Posted by Kevin Brice View Post
    I've run into issues even on Windows 7 running as a limited user, like SpeedEDIT claiming my activation key was invalid until I ran it elevated.
    I shouldn't post so late at night. The patch is, of course, only intended to fix that exact problem. In any event, the problem exists beyond Windows 10, so it'd be great for the patch to be posted for downlevel Windows releases as well.

  6. #6
    'the write stuff' SBowie's Avatar
    Join Date
    Feb 2003
    Location
    The stars at night are big and bright
    Posts
    19,374
    I've checked, and am told that CS can supply the necessary file to those who require it.
    --
    Regards, Steve
    Forum Moderator
    ("You've got to ask yourself one question ... 'Do I feel lucky?' Well, do ya, spammer?")

  7. #7
    VT[2] Aficionado
    Join Date
    Jan 2005
    Location
    Seattle
    Posts
    188
    Quote Originally Posted by SBowie View Post
    I've checked, and am told that CS can supply the necessary file to those who require it.
    I tried that earlier this morning, and the CS agent ended up having to email John about it with the promise of getting back to me. When I previously had SE tell me my key was invalid, a different agent was stumped for several minutes before thinking to ask if I was running elevated. No mention of a patch was made then either. Is there something blocking posting the patch on the download page, potentially reducing support inquiries?

  8. #8
    VT[2] Aficionado
    Join Date
    Jan 2005
    Location
    Seattle
    Posts
    188
    Turns out the patch is in a knowledge base article: https://newtekinc.zendesk.com/hc/en-...ndows-8-and-10

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •