Results 1 to 12 of 12

Thread: My models look better in OpenGL than in the renders

  1. #1

    My models look better in OpenGL than in the renders

    Hello!
    I'm working on some terrains. I exported a model from Vue5 (Yeah, I know. Old) into Lightwave 9.6. The model looked pretty good in Modeler and Layout viewports but when I render it for some reason it looks softer and not of the same quality. I tried different subpatch levels, tried it without subpatching, tried different reconstruction filters. Thought maybe it was just Vue5 model. Then I did a quick cliff edge model and used displacement procedurals. Again it looked pretty decent in the viewport but when I render it with AA it just doesn't look right. Maybe it's just me. The cliff object was done in about 5 minutes. Made it to see if it was Vue5's interaction with Lightwave or something else. I've done displacements before and never noticed this before. I have Windows 7 (64 bit), Dell Inspiron One (All-in-One), 6GB RAM. Graphics card specs are attached. Hope my explanation was clear enough. Thanks for the help.Click image for larger version. 

Name:	Graphics Card Specs.JPG 
Views:	119 
Size:	46.5 KB 
ID:	125796 Click image for larger version. 

Name:	Cliff_Viewport.JPG 
Views:	160 
Size:	188.3 KB 
ID:	125797 Click image for larger version. 

Name:	Cliff_Render.JPG 
Views:	160 
Size:	153.4 KB 
ID:	125798 Click image for larger version. 

Name:	Barney_Fife.jpg 
Views:	114 
Size:	43.4 KB 
ID:	125799

  2. #2
    I've always been here Mr_Q's Avatar
    Join Date
    Mar 2003
    Location
    Burbank
    Posts
    340
    Lower your smoothing angle for the surface. Possibly turn it off if you have enough geo. Especially once you apply texturing.

    Also verify the displacement coordinate space. Make sure your render subDs are matching your display. (if using subDs)

    About all I can think of.
    Kevin "Q" Quattro
    Inhance Digital
    3D Art Director



  3. #3
    In the texture editor try changing the MipMap quality and strenght. Those are designed to help minimize noise and moire but can soften too much.

  4. #4
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    7,897
    Rendering sub-patch level is controlled independently from OpenGL/preview sub-patch level. Are you always using the same value for both?

  5. #5
    Thanks for the feedback! I tried that and got very little difference. After I posted the thought came to mind to try different lights. Lo and behold it seems Area light has some kind of conflict with these kind of scenes. Thankfully, Spherical, Dome, etc. seem to work fine. Perhaps Area Lights, with highly tessellated objects and my graphics card have some kind of conflict. I've attached the images.

    Area:Click image for larger version. 

Name:	Area.JPG 
Views:	107 
Size:	89.1 KB 
ID:	125811

    Directional:Click image for larger version. 

Name:	Directional.JPG 
Views:	97 
Size:	74.9 KB 
ID:	125812

    Spherical:Click image for larger version. 

Name:	Spherical.JPG 
Views:	95 
Size:	63.8 KB 
ID:	125813

    Dome:Click image for larger version. 

Name:	Dome.JPG 
Views:	98 
Size:	74.9 KB 
ID:	125814

    - - - Updated - - -
    Last edited by regenerator; 12-02-2014 at 11:52 AM.

  6. #6
    Quote Originally Posted by Sensei View Post
    Rendering sub-patch level is controlled independently from OpenGL/preview sub-patch level. Are you always using the same value for both?
    Yes, sir.

  7. #7
    Displacement giving nice result but there should be also normal map

  8. #8
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    14,977
    I think the main issue is the very smoothing angle that is set in the surface editor, might help a little to lower smoothing angle as mentioned, but it could also ruin it in terms of getting too sharp edges in the surface where some polyfacets are excluded from the smoothing by the angle set, the surface should have sharp edges only where the geometry is sharp, and there is no way for a shader to handle that as I know of, and as Kevin "q" mentioned, you could turn it of completly, but that means you need a very dense mesh to interpolate the surface look without the aid of surface smoothing, it could give better results since it donīt smooth interpolate the surface..rather hard interpolating it with increased polys.

    This is a typical issue with software that are interpolating it with surface smoothing..and in most cases it looks to smoothed without a lot of sharp detail that you encounter in real terrains, vue with infinite procedural detail has a different approach, unless you are not working with standard terrains in vue, then it is the same case there with terrains looking too smooth, unless a very high resolution is set.

    And as mentioned before, in the objects tab you have subpatch level, wich for landscapes that requires detail should be set to first, and you have two different settings, display subpatch..which is visible in opengl and VPR, then render subpatch that only affects final render, so if you render it not in VPR but in final renders, you have to make sure you set it at the same level as display subpatch, though you can turn display subpatch to zero to move faster viewports when you are done setting the landscape...that wonīt affect the render subpatch level.


    Michael

  9. #9
    Quote Originally Posted by MarcusM View Post
    Displacement giving nice result but there should be also normal map
    That is true but I hardly ever use Normal Maps.

  10. #10
    Quote Originally Posted by prometheus View Post
    I think the main issue is the very smoothing angle that is set in the surface editor, might help a little to lower smoothing angle as mentioned, but it could also ruin it in terms of getting too sharp edges in the surface where some polyfacets are excluded from the smoothing by the angle set, the surface should have sharp edges only where the geometry is sharp, and there is no way for a shader to handle that as I know of, and as Kevin "q" mentioned, you could turn it of completly, but that means you need a very dense mesh to interpolate the surface look without the aid of surface smoothing, it could give better results since it donīt smooth interpolate the surface..rather hard interpolating it with increased polys.

    This is a typical issue with software that are interpolating it with surface smoothing..and in most cases it looks to smoothed without a lot of sharp detail that you encounter in real terrains, vue with infinite procedural detail has a different approach, unless you are not working with standard terrains in vue, then it is the same case there with terrains looking too smooth, unless a very high resolution is set.

    And as mentioned before, in the objects tab you have subpatch level, wich for landscapes that requires detail should be set to first, and you have two different settings, display subpatch..which is visible in opengl and VPR, then render subpatch that only affects final render, so if you render it not in VPR but in final renders, you have to make sure you set it at the same level as display subpatch, though you can turn display subpatch to zero to move faster viewports when you are done setting the landscape...that wonīt affect the render subpatch level.


    Michael
    Thanks for the input. I tried all of those and came to the conclusion that for whatever reason the Area light was the problem. Perhaps a clash with my graphics card. Thankfully the other lights work fine.

  11. #11
    RETROGRADER prometheus's Avatar
    Join Date
    Aug 2003
    Location
    sweden stockholm
    Posts
    14,977
    Quote Originally Posted by regenerator View Post
    Thanks for the input. I tried all of those and came to the conclusion that for whatever reason the Area light was the problem. Perhaps a clash with my graphics card. Thankfully the other lights work fine.

    if you have a terrain to render with naturalistic sunlight, go and get dp_sunsky, it contains additional light models, such as the sk_sunlight, the plugin is free, I would suggest you add the sunsky plugin from
    the textured environment and double click it, once there, select you default light, but then go to that lightīs property and change it in the list, there should now be a new light type called sk_sun, choose that and go down in itīs tab and change mode to manual, so you freely can rotate position the sun direction, otherwise you have to use time controls which can be harder to use when designing light direction.

    thereīs also a script that makes the setup easier, all downloads at the bottom of the page, and make sure to get the right versions...
    http://dpont.pagesperso-orange.fr/plugins/Sunsky.html

    Michael

  12. #12
    Thanks for the Sunsky link. Just downloaded it and will give it a go.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •