Page 1 of 2 12 LastLast
Results 1 to 15 of 18

Thread: LW Render with Alpha looks WRONG in After Effects

  1. #1

    LW Render with Alpha looks WRONG in After Effects

    Hi,

    I am importing a 3D Render from Lightwave with a Premultiplied Alpha in AE as a Targe Sequence.

    If I compare the render when I comp it on top a AE Solid with the Output of Fusion for example I get a very different/wrong comp if there a transparent/Motionblurred parts in the 3D Render.


    Here is a Comparison with a render of 8 Cubes and comped in Fusion and AE (once interpreted as Straight and once as Premultiplied) over White, Black and a Color.Click image for larger version. 

Name:	Alphavergleich.jpg 
Views:	567 
Size:	237.4 KB 
ID:	125445

    Here is the 3D Render and the Alpha Channel:Click image for larger version. 

Name:	Alpharender.jpg 
Views:	181 
Size:	113.9 KB 
ID:	125446


    As you can see the rendering of Fusion is What I would call Right. What is AE doing and why?

    How can I get the same output in AE?

    Thanks

    Alex

  2. #2
    Is your alpha set to sRGB instead of linear?

  3. #3
    No, its set to linear.

  4. #4
    try uncompressed TGA. seems compressed targa has issues in AE. even better, use EXRtrader to export from LW and import all render channels you need into AE in one go. with the AE PROexr plugin you create then a layer comp from this data - one click!
    Last edited by 3dworks; 11-11-2014 at 07:13 AM.
    3dworks visual computing
    demo reel on vimeo
    instagram

    OSX 10.12.x, macpro 5.1, nvidia gtx 980 ti, LW2015.x / 2018.x, octane 3.x

  5. #5
    its not the file format. I tried PNG and others.
    After Effects messes up the render when theres a Premutiplied Alpha.
    Please someone try, I cant be the only one comping 3D renders over Backrounds in AEß

  6. #6
    Quote Originally Posted by mr zero View Post
    its not the file format. I tried PNG and others.
    After Effects messes up the render when theres a Premutiplied Alpha.
    Please someone try, I cant be the only one comping 3D renders over Backrounds in AEß
    Can you post the .lws, .lwo and renders? I know they're just cubes, but It is far easier this way.

    I can try to see if t is something in LW... something in AE... see what the result is in Nuke.. and see if Maya or Modo gives different results as well.
    please power off before disconnecting connecting connectors

  7. #7
    Thanks for testing,

    these are the LW Scene and object:
    Alphatest2.lwsAlphatest2.lwo

    Alex

  8. #8
    oh corks
    Join Date
    Aug 2010
    Location
    end of the line
    Posts
    888
    If things are transparent with bright highlights, try adding the render itself to the alpha. You'll probably need to vary the amount you add and test it. I think that's what the "additive" slider in Fusion does. Highlights on rendered transparent materials don't appear in alphas, but they aren't "see through" in real life. It's generally a problem with all alphas for transparent objects in cg. Fusion has a trick to help with it. No idea if AE does.

    (Disclaimer: it's been 10 years since I last used Fusion. I might be talking cacapooie.)

  9. #9
    Fusion is doing it Right, AE has the Problems with the Alpha. AE has to my Knowledge not something like the additive slider concerning the alpha.

  10. #10
    Try setting your composition settings to 32 bit in After Effects.

  11. #11
    Eat your peas. Greenlaw's Avatar
    Join Date
    Jul 2003
    Location
    Los Angeles
    Posts
    7,164
    I'm not sure I have much more to add to the above but, FWIW:

    I comp in both Fusion and AE, usually with .exr and sometimes .png. It's been working fine for me, but earlier this year, an artist I worked with described a similar issue he was having with his AE comps. Unfortunately, I'm not exactly sure what we were doing differently from each other.

    From Lightwave, I usually render from exrTrader for Fusion, but sometimes I'll render .png for AE. When I render anything in Lightwave, I use the sRGB CS preset (Alpha is Linear of course.)

    I try to always work in 32 bit float space in Fusion, and I might bump it down to 16 bit integer if I run into problems (usually involving super 1 and sub 0 values in blurs or glows.) I usually work in 32 bits in AE but I had to drop it down once because apparently a plugin I was using wasn't fully compatible and I got bad matte lines (probably a similar problem.)

    You might try interpreting the footage in AE using a different Alpha mode. For .png, I think I just use the default Straight Unmatted mode. (I'll check on that later. Admittedly I haven't been using AE for long, and I still use Fusion most of the time.)

    Sorry, I know that's not a lot of helpful info.

    G.

  12. #12
    Newbie Member DesertRat's Avatar
    Join Date
    Nov 2007
    Location
    Tucson
    Posts
    87
    I gave this a try, unfortunately LightWave threw a bunch of "No plug-in of type Node Handler found with name Input" while opening the scene, so my rgb render looks different from yours...

    I attached a picture with a render from AE and some screen grabs of the set-up. I found these 2 tutorials to be useful:

    http://www.digitalartform.com/archiv...annel_a_1.html

    http://www.digitalartform.com/alphaChannel.htm

    I rendered out a frame in LW and saved the rgb to PNG24 and the alpha to PNG24. In After Effects I Inverted the alpha image, then changed its blending mode to Multiply over the background. I Pre-Comped them together and then inserted the rgb frame and changed its blend mode to Linear Dodge. I think you can use Add as well.

    This stuff makes my head spin. Does this look correct??
    (I know that on some of the boxes the surfaces are wrong from my end)
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	fg_alphaxbg.jpg 
Views:	75 
Size:	82.3 KB 
ID:	125479  
    Mac OSX 10.10.2, 2.8 GHz Intel Core i5, 4 GB RAM

  13. #13
    Thanks for helping out everyone!
    I made a few more Tests and I guess I can rule out that it is a LW Problem.
    I made a similar scene in another 3D Programm and get the same bad behavior from AE!
    Normal Pemultiplied Alphas look in an AE comp over a black BG different than the RGB render obver black, that is not right!

  14. #14
    Thanks Clintonman!
    That seems to be the right setting:
    The Project has to be set to 32bit float and then the comp looks normal!
    (Which to me makes no sense as the Targa is 8bit only and in the Projekt settings 8bit is the Default setting when you make a new comp...)

    One of those AE quirks... good to know Fusion is back and free and does those things automaticaly right...

    Thanks all!

  15. #15
    You're welcome. Funny thing is you can make Fusion look like AE by checking "Post-Multiply by Alpha" in the loader nodes import settings.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •