Page 2 of 2 FirstFirst 12
Results 16 to 20 of 20

Thread: Rig made in LW11.6 not working correctly in LW11.6.3

  1. #16
    Registered User
    Join Date
    Aug 2013
    Location
    Belgium
    Posts
    43
    Thanks Lino for joining this thread,

    At first I thought it was a bug, but indeed if you've changed some functions in LW that causes this issue then it made sense. Or at leased I know now what causes it. This character was a simple rig and was easy to solve for the new LW11.6.3 fix. But I discovered this issue when I opened up a ( more complex ) rig I've worked on. Meaning that I have to find all the conflicts in that rig caused by the LW11.6.3 bug fix. So a lot of work if I would like to use that rig with LW11.6.3 and future upgrades.

    Anyway, I fixed this example by unselecting the World option next to Rotation Item in the Motion option for that bone. The bone was not parented nor was I using "Follow". Attached to this thread a screen cap to clarify. I'll send you a link by mail where you can download this scene file.

    Greets,
    Carlo



    Freelance Lightwave Animation at www.c3d.be
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	rig-probleem_oplossing.jpg 
Views:	84 
Size:	329.2 KB 
ID:	123940  

  2. #17
    TD/Animator lino.grandi's Avatar
    Join Date
    Jun 2003
    Location
    Rome
    Posts
    1,701
    As I said in a previous post, I was pretty sure the problem was linked to the Same As Item World Coordinates option. Good you fixed that!
    Lino Grandi
    3D Development, LightWave 3D Group/NewTek, Inc.

    https://www.lightwave3d.com/

    LightWave 3D Group YouTube channel:

    http://www.youtube.com/user/Official...?feature=watch

    My YouTube Channel:

    http://www.youtube.com/user/linograndi?feature=mhee

  3. #18
    "OH NO!", Joseph Joestar ncr100's Avatar
    Join Date
    Feb 2003
    Location
    San Francisco
    Posts
    1,100
    Blog Entries
    2
    Is this something which could be magically 'fixed' with a Python script? If so, what would that script need to do? Only curious.
    -Nick
    audio: Ö ¤ wk Py

  4. #19
    Super Member spherical's Avatar
    Join Date
    Dec 2004
    Location
    San Juan Island
    Posts
    4,686
    Quote Originally Posted by ncr100 View Post
    lol - Think "is not equal to" when you see the != thing.
    I know that. Standard Regex; used in a lot of programming languages, of which I am conversant in at least 6. (Note the "That's true" part.) Still doesn't clear up what you mean by stating the equation. IOW... I don't get the joke.
    Blown Glass ˇ Carbon Fiber + Imagination

    Spherical Magic | We Build Cool Stuff!

    "When a man loves cats, I am his friend and comrade, without further introduction." - Mark Twain

  5. #20
    TD/Animator lino.grandi's Avatar
    Join Date
    Jun 2003
    Location
    Rome
    Posts
    1,701
    Quote Originally Posted by ncr100 View Post
    Is this something which could be magically 'fixed' with a Python script? If so, what would that script need to do? Only curious.
    Sure....both LScript and Python could do that easily, just selecting the interested bone and disabling World Coordinates for the Same As Item rotation. That would solve the problem with this specific rig.

    Once again I want to underline that Same As Item world coordinates behavior has been fixed because it was not working as it should have (well...we can say it was "broken" for items Record Pivot Rotation was used on....you simply couldn't use World Coordinates in that case before).
    Lino Grandi
    3D Development, LightWave 3D Group/NewTek, Inc.

    https://www.lightwave3d.com/

    LightWave 3D Group YouTube channel:

    http://www.youtube.com/user/Official...?feature=watch

    My YouTube Channel:

    http://www.youtube.com/user/linograndi?feature=mhee

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •