Results 1 to 3 of 3

Thread: question about polygon counts

  1. #1
    Registered User octopus2000's Avatar
    Join Date
    Jan 2008
    Location
    the future
    Posts
    247

    question about polygon counts

    when i create a model in modeler with a polygon count of 500 how come that object becomes 8000 when i send it to layout? is it possible to reduce the subdivisions in layout?

  2. #2
    In Layout...

    - Select your object
    - hit "P" to open the properties panel
    - Where it says "Display Subpatch Level", this number dictates the number of polygons will be applied to subpatched geometry. The default is 3, but I typically work with it set to 1. A setting of zero turns subpatching off.
    Professional-level 3d training: Ryan's Lightwave Learning
    Plugin Developer: RR Tools for Lightwave

  3. #3
    Super Member jboudreau's Avatar
    Join Date
    May 2003
    Location
    Halifax
    Posts
    939
    Quote Originally Posted by octopus2000 View Post
    when i create a model in modeler with a polygon count of 500 how come that object becomes 8000 when i send it to layout? is it possible to reduce the subdivisions in layout?
    Hi octopus2000

    If you send a model with 500 polygons over to layout that is not SubPatched it will come in as 500 polygons. If you send in a model with 500 polygons that is SubPatched then it will use the number you have for your SubPatch level and times it by that same number(by itself). then it will take the sum of that number and multiply it by the number of polygons in your model. once it does that it will double that number because it has to split all your quad polygons in half (Triangulates the polygons)

    for example for a 500 polygon model if you have the SubPatch level set to the following:

    SubPatch at level 0 = (0 x 0) x 500 = 500 polygons
    SubPatch at level 1 = (1 x1) X 500 x 2 = 1000 polygons
    SubPatch at level 2 = (2 x 2) X 500 X 2 = 4000 polygons
    SubPatch at level 3 = (3 x 3) x 500 x 2 = 9000 polygons

    This is based on a model that is completely made up of quad polygons.

    so to answer your questions if you want it to only have 500 polygons set your SubPatch level to 0.

    You can reduce the SubPatch level by selecting your model and going to properties or press p on the keyboard. You will see two options Display Sub Patch level and Render Sub Patch level.

    Display SubPatch level - Is the level that will be used in your viewport for viewing. (This is used so if you have a model with a lot of polygons you can set it lower so it won't slow down your viewport and you will be able to work with it easier)
    Render SubPatch Level - Is the level that your model will be at during rendering. (This is used so you can set your model to a higher polygon count only during rendering this won't effect what you see in you openGL viewport)

    Also in modeler once you SubPatch your 500 polygon model it will still say you only have 500 polygons until you freeze your model using Ctrl + D. This will tell you depending on your subpatch level how many polygons there will be once you bring over your model to layout. What every you have your SubPatch level set to in modeler it will be the same when you save your object and bring it over to layout. In modeler press the letter o on your keyboard it will bring up the general options panel. Here you will see a setting called SubPatch Division - this is where you can change your SubPatch level in Modeler

    Hope this makes sense.
    Last edited by jboudreau; 04-27-2014 at 08:30 PM.
    VFX Artist / 3D Animator
    Animatrix Productions

    Dell T7600 Dual XEON E5-2687W 3.8GHz / Dell M6700 i7 -3940XM 3.9GHz
    64GB Ram / 32GB Ram
    Nvidia Quadro K5000 / Nvidia Quadro K5000M
    Windows 7 x64

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •