Results 1 to 7 of 7

Thread: How can I obtain a correct shadow on my rocks?

  1. #1
    Registered User
    Join Date
    Aug 2013
    Location
    Chile
    Posts
    15

    Question How can I obtain a correct shadow on my rocks?

    Hi, I've been working on a small project for several weeks. Everything is modeled in Lightwave and then imported to Unity. I'm almost done but my rocks aren't looking good in Unity. Here is the example image, which shows clearly what I'm talking about.

    Click image for larger version. 

Name:	weird_shadows.jpg 
Views:	171 
Size:	143.2 KB 
ID:	117506

    I've tried this so far with no luck:

    1) I know LW has the built in the "smoothing" feature within the Surface Editor. This makes the shadows look correct since they're smoothed out.
    So for Unity I've read that this can be achieved in a similar manner by applying the "smoothing angle" feature under Normal & Tangents within the Import panel, and then baking the object.

    2) I've also tried to pull back certain points within each affected poly in order to try to eliminate any 90° tangents that can produce these type of shadows.

    Click image for larger version. 

Name:	weird_shadows2.jpg 
Views:	174 
Size:	96.1 KB 
ID:	117505

    As you can see in this image the rocks have been baked. The LOD0 model looks better shaded since it has more geometry. But in the LOD1 model, I still see those per polygon shading shadows. Not good.

    Any suggestions really appreciated!

  2. #2
    Hi, i have few sugestions.

    I always exporting from Layout. In last 11.6 FBX exporter is not working correct (i had this situation few time and report this). Objects in Unity react bad on lighting. For now try export from 11.5 Layout.
    You should always receive good result in Modeler, with smoothing value. I using usulally values between 50-70. In Unity importer normals should be on import.

  3. #3
    Registered User
    Join Date
    Mar 2010
    Location
    SATown
    Posts
    643
    Hmm. That's weird. Any chance you could attach the FBX objects?

    I usually set the normals to calculate and then I play with the smoothing angle until I get the look I want. And that fixes 99% of the problems I've had.
    But again, it might take less time to just look at the model.

    -Chilton

  4. #4
    Registered User
    Join Date
    Aug 2013
    Location
    Chile
    Posts
    15
    Hi, yes I'm using 11.5, and export from layout. Also I have had no other problems of this kind with other type of geometry. I've used both methods, Import and Calculate, for the smoothing angle. So no luck yet.
    Chilton, I leave the FBX file here for you to download.
    I'll see what else I can find out. Thanks to both of you, Marcus and Chilton.

  5. #5
    Registered User
    Join Date
    Oct 2005
    Location
    USA
    Posts
    1,243
    rock_test.fbx

    I just exported from Layout with smoothing on set on the rock material and it worked fine.

    Does it look good in Unity ( I tested in my custom fbx importer for another engine) ?
    Last edited by warmiak; 10-07-2013 at 08:09 AM.

  6. #6
    Registered User
    Join Date
    Mar 2010
    Location
    SATown
    Posts
    643
    Just dragging those rocks into Unity gives me this result.
    I wonder what's going on here. Could you try exporting the rocks, lights, camera, and background as a unity package?

    Click image for larger version. 

Name:	Screen Shot 2013-10-07 at 11.50.09 AM.png 
Views:	120 
Size:	98.3 KB 
ID:	117519

    -Chilton

  7. #7
    Newbie Member
    Join Date
    Apr 2011
    Location
    Austria
    Posts
    19
    Probably a bit late but my guess is the pixel light count. Under "Edit" -> "Project Settings" -> "Quality" there is a field for "Pixel Light Count". By default this is set to two. That means if you have more than two lights in your scene, the exceeding lights behave as vertex lights resulting in a low quality shading because the shading is applied from vertex to vertex based on the geometry and not from pixel to pixel based on texture.
    If that is the problem increasing the "Pixel Light Count" solves it.
    Last edited by Empedokles; 10-24-2013 at 12:25 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •