Results 1 to 7 of 7

Thread: Good reviews will help promote SpeedEDIT!

  1. #1
    SciEngArtist PabloMack's Avatar
    Join Date
    Dec 2007
    Location
    Houston, Texas
    Posts
    348

    Good reviews will help promote SpeedEDIT!

    I was surprized to find that SpeedEDIT is sold on Amazon.com. I wrote a glowing review for SE under an entry sold by Adorama who I have used in the past but did not buy SE from them. I was also puzzled that mine is the only review for SE on Amazon's website. So far the review has 5 out of 5 people found the review to be helpful. Hopefully Newtek has five new customers because of my positive review. If Newtek gets a lot more sales for SE, there will be an influx of more cash and the company will have no alternative but to put a higher priority on its development. Amazon is certainly my most important retails buying source and I am sure that is true for many other people. I encourage those of you who really like SE to write more positive reviews on Amazon's website. It is not necessary that you buy the product on their website in order to write a review. You only have to register with them.
    Last edited by PabloMack; 01-27-2013 at 09:21 AM.

  2. #2
    SpeedEDIT is an awesome tool, I can't run in on my HP ENVY DV6 Laptop from Walmart tho so I've resorted to my Priemiere CS5.5 backup, not as fun but also a great tool. I have to find another older machine to run the worlds most advanced & intuitive editor...go figure. - Shawn NT

    NDI Camera
    TriCaster Mini Advanced Edition
    Lightwave 11
    SpeedEdit 2.5

    Music by www.soundtraxxmusic.com

  3. #3
    Lynn Cress lcress's Avatar
    Join Date
    Feb 2005
    Location
    Free State
    Posts
    299
    Great idea Pablo Mack. Added my $0.02 to the SE reviews on the Amazon site yesterday.

  4. #4
    Registered User tonyvdb's Avatar
    Join Date
    Jan 2006
    Location
    Edmonton, Alberta, Canada
    Posts
    229
    Hard to write a positive review when SE2.5 does not work on my Dell XPS Win7 64bit i7
    I have had to stay with 2.1 in order to have it work correctly. I have tried so many things to get it to work even submitting a report to Newtek (no help at all). So far nothing anyone else has suggested helps.
    SpeedEdit2
    Dell XPS8300 i7 core AMD6700 graphics 12gb ram
    LG BluRay burrner
    Amiga 4000D VT Flyer in tower
    JVC Digital S BR-D85U
    Sony EVO9850, Panasonic AG7150

  5. #5
    I have a Dell XPS 8100 64 bit and it works for me---The only issue that I recall was that you had to set the SE shortcut to run with administrator privileges or it would not run

  6. #6
    Registered User tonyvdb's Avatar
    Join Date
    Jan 2006
    Location
    Edmonton, Alberta, Canada
    Posts
    229
    Quote Originally Posted by Richvideo View Post
    I have a Dell XPS 8100 64 bit and it works for me---The only issue that I recall was that you had to set the SE shortcut to run with administrator privileges or it would not run
    Mine will crash during the rendering of the project. Sometimes at the beginning just as you hit render and other times somewhere during the render. There is no specific time. SE will simply shut down and exit the program.
    It works fin as long as I stay with 2.1 and not upgrade to 2.5.
    SpeedEdit2
    Dell XPS8300 i7 core AMD6700 graphics 12gb ram
    LG BluRay burrner
    Amiga 4000D VT Flyer in tower
    JVC Digital S BR-D85U
    Sony EVO9850, Panasonic AG7150

  7. #7
    Are you rendering out to a RAID drive?
    What format are you rendering out to--does it do the same thing no matter the format?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •