Results 1 to 3 of 3

Thread: Instance with hierarchy not work fine lw 11.0.3 under win or mac

  1. #1
    Mad Doctor pixelinfected's Avatar
    Join Date
    Jan 2004
    Location
    Santa Margherita Ligure
    Posts
    622

    Instance with hierarchy not work fine lw 11.0.3 under win or mac

    I just did a simple animation with flocking.
    I build a butterfly, three layers, a body, and two plane for wings.
    i build an emitter and a director, i did a simulation ( i found some fault about scale and flocking... but any way it's a instance thread..)
    i use instance to attach butterflies to crown, i checked the option to have instance with hierarcy, in preview opengl i see body and wings but in render i see only bodies... like you can see on picture.
    i found this work under lw 11.03 under win and macOs. Any ideas?

    http://img145.imageshack.us/img145/5...archyerror.png
    Danger! Mad Scientist at work

    I'm a mad genius, a mad scientist, someone like dr. jeckill and frankestein with a bit of Bugs Bunny.

  2. #2
    "OH NO!", Joseph Joestar ncr100's Avatar
    Join Date
    Feb 2003
    Location
    San Francisco
    Posts
    1,101
    Blog Entries
    2
    I see your heirarchyerror image. I see also the "Corpo01" object being associated with the Instancer. I imagine Corpo01 is the body? I understand then how the scene shows only the body during the render. The only object being instanced is the one layer of the butterfly.

    I do not understand why the scene shows the Corpo01 + 02 + 03 in preview OpenGL. That is a mystery to me.

    But, you want to instance the whole butterfly.

    Solution:
    1 Add a Null. Name it "Butterfly Parent"
    2 Open Scene Editor
    3 Drag / drop all three layers of your butterfly to be children of Butterfly Parent
    4 Change your Instancer (as shown in the heirarchyerror.png image) to instance Butterfly Parent. Remove the Corpus01 object.

    Try rendering that.

    EDIT (Attaching my basic 3-layer object experiment. NOTE: It has no Flocking...perhaps that difference is important?)

    EDIT 2 I think I see how my example is not appropriate to the question. Looking into flocking now ....
    Attached Files Attached Files
    Last edited by ncr100; 01-05-2013 at 11:16 PM.
    -Nick
    audio: Ö ¤ wk Py

  3. #3
    "OH NO!", Joseph Joestar ncr100's Avatar
    Join Date
    Feb 2003
    Location
    San Francisco
    Posts
    1,101
    Blog Entries
    2
    I have my scene working with flocking now. I deleted my HV Emitter (that was my mistake) and added to my "All Boxes" (Butterfly Parent) a "Flock Generator" plugin instance to the Geometry of the object's Properties.

    I added a Flock Director and keyframed it. All 3 layers of my object now fly around. If I had your butterfly object then I presume it too would fly around as a whole butterfly, and not one that had its wings removed. I've attached this updated scene.

    You still have one issue which perplexes me. The preview does not look like the render. I suppose it's you have some Rendering settings set up which ... I don't know ... block wings? Are the wings special in any way? Are they using subdivision surfaces? I know there are settings which, at render time, display subdivision surfaces differently than are seen during OpenGL preview time.

    Nick

    EDIT: Is it a 2-faced surfaces thing? Are the normals pointing away from the camera for all but the one one butterfly?

    EDIT 2: I made a video http://youtu.be/nLRqlcMxr0k
    Attached Files Attached Files
    Last edited by ncr100; 01-05-2013 at 11:54 PM.
    -Nick
    audio: Ö ¤ wk Py

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •