Results 1 to 9 of 9

Thread: What happened to the Lightwave Product Website?

  1. #1
    C++ Systems Developer Chrizto's Avatar
    Join Date
    Sep 2008
    Location
    Norway
    Posts
    175

    Thumbs down What happened to the Lightwave Product Website?

    I see that Newtek has made the decision of removing their old product specific website and replacing it with a dull standard page...

    I don't think this is the way to recruit newcomers to Lightwave.
    The earlier version of the site was full of nice tutorials, videolinks, product information and cool pictures, while now it is just plain dull!

    If I where a new user and encountered this site, I would not be very tempted to try out Lightwave!

    Come on, Newtek, let's get this product page back to life...
    Homebuilt PC, Asus P75, Intel Quad Xeon 3.2 ghz,16 GB DDR3 1233 mhz RAM, Nvidia GTX FX 550Ti 1GB

  2. #2
    They want to keep this stuff a secret!
    Didnt you know?
    lw_chanlum [free shader and node x32] <HERE!>
    lw_chanlum [advanced node x32, x64, ub and osx] <HERE!>

  3. #3
    What do you have against Vanilla CMS templates ?
    Model: MacBook Pro 10.6.4 - 2.66 GHz - 4GB - NVD GF GT 330M
    Render: Win7 64 - Core 2 Quad Q9550 2.83GHz - 8GB

  4. #4
    You've just recently come back to Lightwave and discovered this haven't you. There have been pages and pages of posts bitching about this and a zillion great suggestions and offers to help, even a few teasing announcements from Newtek that they were in the process of upgrading the site, but as you can see none of that matters because Newtek's "new" website remains dull as ever. I have no word's left on the subject and have made peace with it's awfulness.

  5. #5
    it'd be good also for the top image to be a video link...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Play.gif 
Views:	91 
Size:	1.29 MB 
ID:	104654  
    LW vidz   DPont donate   LightWiki   RHiggit   IKBooster   My vidz

  6. #6
    ... Or if the gallery images had ANY credits ? :/
    Model: MacBook Pro 10.6.4 - 2.66 GHz - 4GB - NVD GF GT 330M
    Render: Win7 64 - Core 2 Quad Q9550 2.83GHz - 8GB

  7. #7
    Super Member Snosrap's Avatar
    Join Date
    Aug 2004
    Location
    Ohio, USA
    Posts
    4,923
    Seems alright to me.

  8. #8
    C++ Systems Developer Chrizto's Avatar
    Join Date
    Sep 2008
    Location
    Norway
    Posts
    175
    Quote Originally Posted by djwaterman View Post
    You've just recently come back to Lightwave and discovered this haven't you.
    True!
    Homebuilt PC, Asus P75, Intel Quad Xeon 3.2 ghz,16 GB DDR3 1233 mhz RAM, Nvidia GTX FX 550Ti 1GB

  9. #9
    Registered User hazmat777's Avatar
    Join Date
    Mar 2004
    Location
    Seattle
    Posts
    616
    I've posted about this before, but here we go again!

    Why on the first screen that visitors will see are there two threads that are closed?

    SINCE 2010 !

    Why can't NewTek create a place so we can still get to this information, yet get it out of new potential customers faces?
    "I don't have it... you want half my omelette?"

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •