Results 1 to 6 of 6

Thread: MDD Network Rendering Issues with BNR

  1. #1
    Mission Man DaveG's Avatar
    Join Date
    Jul 2003
    Location
    LA California
    Posts
    48

    MDD Network Rendering Issues with BNR

    We've run into a situation where baked displacement via MDD is not rendering on our rendering farm. We are using BNR to render out the frames.

    Can you tell me what pitfalls we should be avoiding?

  2. #2
    Super Member nickdigital's Avatar
    Join Date
    Nov 2006
    Location
    Burbank, California USA
    Posts
    4,576
    Do your nodes have the same access to the plugins and mdd file as your workstation(s)?
    My opinions and comments do not represent those of my employer.
    Profile piece
    2010 Reel
    'The X's' Reel

  3. #3
    Mission Man DaveG's Avatar
    Join Date
    Jul 2003
    Location
    LA California
    Posts
    48

    MDD file yes

    We have tested the files on the local workstations and it is fine however when we try to render the MDD files via BNR the displacement does not work.

    We are not using the plugins on the content server but they are 10.1 plugs

  4. #4
    I have had one issue with later LW versions and MDD, though I thought it was a plugin install issue on the farm... I was able to use DP's MDD Pointer, but not the built-in MDD reader.

    Try that... However, it is most likely that the nodes are unable to access the MDD file. Put the MDD file in the scene directory. On the render nodes, watch the LWSN process and look for errors (or enable error logging with the BNR client and read the output from LWSN that way).

    Look at the .lws file with a text editor. See how the scene file has the path to the MDD file(s) stored. May sure this same path works from the render nodes. (e.g. you may have the drive mapped as F:\ on your workstation, but \\myserver\myshare\on the render nodes.

  5. #5
    Red Mage Celshader's Avatar
    Join Date
    Feb 2003
    Location
    Burbank, California
    Posts
    1,817

    Red face I think exosoul ran into a similar problem earlier this year...

    Quote Originally Posted by DaveG View Post
    We've run into a situation where baked displacement via MDD is not rendering on our rendering farm. We are using BNR to render out the frames.

    Can you tell me what pitfalls we should be avoiding?
    This may not be helpful, but exosoul ran into a similar problem a month or two ago with BNR and another displacement plug-in (Bullet?). A test with the Deadline render farm controller worked fine on the same scenes.

    I'll echo what others have already written here -- make sure the farm can see all the plug-ins.
    Jen's 3D -- LightWave stuff.
    Jen's 2D -- my comic book.

    Python is my smashing board. LightWave is my S.M.A.K.

  6. #6
    I can tell you that there is nothing with regard to BNR itself that would make this fail. It is not the render controller. It may be the plugin setup on the render farm, but it is definitely not the controller itself.

    You can check the configs in your net render directory that BNR created and be sure all the plugins are there. But the best way to troubleshoot this is to look at the output from LWSN while the scene is being loaded. Look for plugin failed messages, and file not found messages.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •