Results 1 to 4 of 4

Thread: lscript position and rotation not working

  1. #1
    Newbie Member
    Join Date
    Jan 2004
    Location
    Orange County, CA
    Posts
    10

    lscript position and rotation not working

    I'm using Lightwave 10.1

    In layout, I created a simple lscript to add a light

    AddSpotLight ("Blue_Light");
    Position(-2,-2,-2);
    Rotation(45,45,0);

    The light is added, but the position and rotation values stay at 0.

    I ran a 3rd party script to generate a 4 point light setup, and it worked fine except for position and rotation, which remained at 0.

    Any suggestions??

    Thanks

  2. #2
    Super Member nickdigital's Avatar
    Join Date
    Nov 2006
    Location
    Burbank, California USA
    Posts
    4,576
    Does Autokey need to be on?
    My opinions and comments do not represent those of my employer.
    Profile piece
    2010 Reel
    'The X's' Reel

  3. #3
    Newbie Member
    Join Date
    Jan 2004
    Location
    Orange County, CA
    Posts
    10

    my hero

    Thanks much... that did the trick. I usually leave it off, so apparently all I have to do is find a way to enable it when the script runs, then turn it off.


  4. #4
    Super Member nickdigital's Avatar
    Join Date
    Nov 2006
    Location
    Burbank, California USA
    Posts
    4,576
    Cool. If you can check to see if Autokey is on, you might want to put a condition check in. Some of the things in lscript are just toggles so you would just be toggling the existing state instead of actually turning it on or off.
    My opinions and comments do not represent those of my employer.
    Profile piece
    2010 Reel
    'The X's' Reel

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •