Results 1 to 6 of 6

Thread: Re-ordering points for Shifer?

  1. #1
    Big fan of coffee raw-m's Avatar
    Join Date
    Jul 2003
    Location
    London
    Posts
    2,342

    Re-ordering points for Shifer?

    Hello everyone

    I'm trying to use this rather clever extruding plugin - Px_Bezier 011 (it works on a Mac!!) on a custom shape in combination with DPs Shifter node. I'm getting some very strange jumping when the shifting is taking place. After a bit of research I think it has something to do with the order in which the point ids are created by PX_Bezier.

    Is there a script out there that is clever enough to re-order the names of each point (as if my custom shape was rail extruded rather than Px_Beziered)?

  2. #2
    Member
    Join Date
    May 2006
    Location
    France
    Posts
    4,208
    I tried Px_Bezier 08 on a PC,
    both Tube and Extrude modes,
    as I see, points are correctly ordered
    you can easily verify this with the
    Modeler info panel,
    I got also the result object
    working with Shifter,
    I just removed the base shape
    since it is placed on the same
    layer.

    Denis.

  3. #3
    Big fan of coffee raw-m's Avatar
    Join Date
    Jul 2003
    Location
    London
    Posts
    2,342
    Thanks for your response Denis.

    I've attached the result I'm getting on a simple extrude - mid-shift. I've been using Px_Bezier 11 and Px_Bezier 14 with the same results. LW and Px_Bezier extrudes don't match so I wondering if there is some fix I could run?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	extrude.png 
Views:	66 
Size:	10.9 KB 
ID:	85536  

  4. #4
    Member
    Join Date
    May 2006
    Location
    France
    Posts
    4,208
    I tried also the Px_Bezier 014 but still PC,
    same correct point index alignment,
    the 6 faces per segment is made with 'Tube'
    the other 4 faces Bezier extrudes with a
    quad shape.
    Couldn't say if this comes from your settings
    (I used very basic) in the Modeler Tool
    or from the UB version.

    Tube_Bezier.ZIP

    Denis.
    Last edited by dpont; 06-10-2010 at 06:58 AM.

  5. #5
    Member
    Join Date
    May 2006
    Location
    France
    Posts
    4,208
    Ok I didn't tried the Extend mode,
    wasn't in the '08' version,
    and point index order change,
    even reversed in some cases,
    this is not important for building
    polygons just annoying for
    animating for Mac and without
    Fertilizer, may be fixable by
    Pictrix but don't know.

    Did you tried the Extrude mode
    with a polynormal Z- oriented?

    Denis.
    Last edited by dpont; 06-10-2010 at 08:04 AM.

  6. #6
    Big fan of coffee raw-m's Avatar
    Join Date
    Jul 2003
    Location
    London
    Posts
    2,342
    Denis, I'm so happy!!!! I got it to work Extrude mode, as you suggested. Got to be careful not to go too mad with the "twist" option, as well. For more predictable results I'm finding that merging all the polys that make up your shape into one poly also helps. Thanks again.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •