PDA

View Full Version : help please - black glass



DHudson
07-02-2009, 08:05 AM
Hello ... I am rendering a room scene and the window glass in the room is solid black- though it should be clear, having used one of LW's glass presets. Did I click on some button to mess my glass up? I see the "sun" light from outside the window as shining on the floor inside. help :(

Thank you so much in advance

ericsmith
07-02-2009, 08:29 AM
this may be a stupid question, but is there anything on the other side of the glass?

by default, the backdrop in any render will be solid black. So if you haven't put something in the background (even if it's just a background image), that's what you would get.

eric

jameswillmott
07-02-2009, 08:30 AM
EDIT: (beaten to the post by one minute)

DHudson
07-02-2009, 08:43 AM
There is a suburban scape image in the background. I was getting good renders with the glass as transparent and you could see the background image, but now suddenly the glass is solid black. Even the preview image in the surface editor is solid black. I have switched to different glass presets, but that doesn't help.

Nangleator
07-02-2009, 09:21 AM
Maybe you need Ray Recursion set above 2 or 3, or perhaps select Ray Trace Transparency.

Lightwolf
07-02-2009, 09:25 AM
If you are raytracing transparencies, and your background image is a backdrop image (compositing tab) then it won't be visible through the refraction/transparency (it's also not visible in reflections).
This is because a backdrop image has no real position in space.
You'll need to some geometry to your scene (a plane with a front projection mapped image and the luminosity set to 100%, diffuse to 0% will do).

If _that_ is the culprit.

Cheers,
Mike

DHudson
07-02-2009, 09:31 AM
The suburban scape image is on a piece of geometry on the other side of the windows, sorry I should have worded that differently.

Lightwolf
07-02-2009, 09:39 AM
The suburban scape image is on a piece of geometry on the other side of the windows, sorry I should have worded that differently.
Well, you never know ;)

Does it show through if you don't raytrace transparencies or refractions?

Cheers,
Mike

DHudson
07-02-2009, 11:29 AM
I have both ray trace transparency and refractions on. And still the glass is solid black. I can't figure this out. :(

RudySchneider
07-02-2009, 01:20 PM
It might help if you posted a screen shot of your Surface Editor and/or Node settings.

toby
07-02-2009, 06:37 PM
Make sure the background polygon is not set to Unseen to Rays, and it's checked on in the surface editor -

Also, the glass surface environment options must not be set to Spherical Map only or Backdrop only.