PDA

View Full Version : Smoothing particle animation



Philbert
07-01-2009, 06:17 PM
I have a fairly simple animation where a few particles explode out from a point, then a wind emitter carries them in a spiral so that they spin around while exploding out. Now, attached to each particle is a small sphere object, because I use motion blur to create streaks from the particles.

The problem is that the streaks do not have a smooth curve to them, it's jagged, like a cylinder with not enough polygons. You can see it with a couple of the streaks in the attached image. Any thoughts on smoothing the curve?

07-02-2009, 06:45 AM
Motion blur round bends ? - amazed you've found a setting that gets you that close!
did you try just letting each particle emit a string of slowly fading particles that don't inherit it's motion

prometheus
07-02-2009, 09:15 AM
Yeah..I would probably use particle trails instead, I think it would give much more smoother streaks behind it, I have some sample clips of it somewhere..but Im at work right now.

Michael

Philbert
07-02-2009, 12:20 PM
Motion blur round bends ? - amazed you've found a setting that gets you that close!
did you try just letting each particle emit a string of slowly fading particles that don't inherit it's motion

Interesting idea, I don't know much about particles emitting particles.

What I've got here may not be as fancy as you think. Any of the motion blur settings show a result similar to this. I just cranked the blur length up to 400%.

Mr Rid
07-02-2009, 01:23 PM
You should not be getting jagged blur like that unless you are using vector blur(?). What are your camera settings?

blur length 750
74862

I am seeing another odd thing though... as I turn up the blur length more spheres begin to not blur correctly for some reason.

1000
74863

Mr Rid
07-02-2009, 01:32 PM
Interesting idea, I don't know much about particles emitting particles.

To have particles emit from other particles-

Parent a second emitter to the first one, then set child emitter Nozzle to Parent-Emitter.

Under Etc tab you will want to adjust the Parent Motion value.

Philbert
07-02-2009, 02:03 PM
BTW you can see this effect where I did it before in the very first shot of my demo reel. What I'm doing now is trying to improve on that shot.

http://www.philnolan3d.com/ (click Demo Reel)

Edit: OK I got the particles to emit particles. As you can see in this video the particles trail also shows the sharp corners, so I think it has something to do with the wind.
http://screencast.com/t/HXRFfnpfGJw

Mr Rid
07-02-2009, 03:19 PM
Ok, now I see whats going on. PFX do not calculate subframes, which is my biggest complaint about PFX (a big problem with collisions). Your particles are moving so rapidly that the straight line you see is the path of the particle over one frame. If you set your General Pref to Fractional Frames and scrub the frames slowly you will see how everything moves between frames. Particles will go along then snap to a new direction at each frame.

The workaround (yet again) is to raise your scene frame rate and scene length. So you might switch 24 fps to 120 fps, and a 60 frame animation to 300 frames (x5). Calculate and save PFX motion. Then switch back to 24 fps. Now you have an excess of 120 fps of velocity info compressed into 24 fps so the curves will smooth out. This trick does not always work smoothly in complex scenes with collisions and voxels where some behaviors will change and some envelopes and values have to be individually tweaked. Keep in mind also that you can adjust the playback speed of baked PFX separately under File tab, Playback Speed.

I also notice your demo animation is post slowed down anyway so am wondering why you could not just slow down your animation in the first place, unless you want the strobe effect.

Philbert
07-02-2009, 03:29 PM
Thanks, I'll look at that. The reason for not slowing it down in LW is that it already takes a long time to render, like 12 hours at least, so I wouldn't want it to take any longer.

Mr Rid
07-02-2009, 05:08 PM
...The reason for not slowing it down in LW is that it already takes a long time to render, like 12 hours at least, so I wouldn't want it to take any longer.

I'll bet there are ways to greatly speed that render time. It looks like you are rendering 45 or 60 frames? Does not look like something that should take that long to render.

Also consider this interesting approach to 'light trails' using lazy points-
http://www.newtek.com/forums/showpost.php?p=17671&postcount=6

prometheus
07-02-2009, 05:15 PM
this got me remembering this experiments I did some time ago..no particle trails thou, only directional wind..with procedural textures on the vector channels..might be of interest if you havent seen it.

thread over at spinquad
http://www.spinquad.com/forums/showthread.php?t=21294

Michael

Mr Rid
07-02-2009, 05:55 PM
this got me remembering this experiments I did some time ago..
Michael

Purtty!

Philbert
07-02-2009, 06:26 PM
OK now I have it looking nice with particles but I can't save it with any transparency for comping back into the scene. If I try it just renders solid black images. Only if I render 24 bit will it show the particles in the saved files.

http://i151.photobucket.com/albums/s136/willohmsford/th_cg_sphere_HVs_088.jpg (http://i151.photobucket.com/albums/s136/willohmsford/cg_sphere_HVs_088.jpg)


I'll bet there are ways to greatly speed that render time. It looks like you are rendering 45 or 60 frames? Does not look like something that should take that long to render.


The long render time is from the main focus of that shot that you can see on my reel. The particles only take like 7 minutes for 120 frames.

@prometheus Very cool!

Mr Rid
07-02-2009, 09:12 PM
Am not understanding about 'black images' do you mean in the alpha channel? .. save with "LW_TGA32" to have an alpha channel to comp with. Or "LW_OpenEXR_RGBAFP" to have extra color range to play with in comp. Be sure you do not have any matte object in the background.

I still dont see what takes long to render. :)

Philbert
07-02-2009, 09:26 PM
No if I save TGA32 I just get a solid black image, I didn't even look at the alpha, but the main image is black. Regardless I solved that by rendering TGA24s and setting the Blending Mode to Lighten.

Mr Rid
07-02-2009, 11:40 PM
No if I save TGA32 I just get a solid black image, I didn't even look at the alpha, but the main image is black. Regardless I solved that by rendering TGA24s and setting the Blending Mode to Lighten.

Well something's awry. What app are you loading the images into? Have you saved TGA32s before without a problem, or is this something new? Then am wondering what you get if you F9 and save a TGA32 from the image viewer.

Philbert
07-03-2009, 12:34 AM
Loading into After Effects and also IrfanView. Never had a prob with TGA32 before. Same thing happens from the F9 save.

The finished animation. Is the text animation too busy?
http://www.youtube.com/watch?v=Xy1XwNPBMdQ

Mr Rid
07-03-2009, 12:44 AM
The finished animation. Is the text animation too busy?
http://www.youtube.com/watch?v=Xy1XwNPBMdQ

I think so. I prefer the previous composition. I think the now brighter particles upstage the text. The darting motion on the text makes it less readable.