PDA

View Full Version : object not smooth



Xcape
06-14-2009, 11:29 PM
Hi,

How come when I tab to subpatch my object in perspective viewport is rough where as the video I'm following along is perfectly round.

Thanks,
Xcape

Silkrooster
06-15-2009, 12:13 AM
A couple of issues can cause that.
1)Not enough edges to support the polygons.
2)The quality of the sub patch is set too low. -->This is probably more likely to be it.

Press the lowercase O key on keyboard and change the value for sub patch divisions or catmall-clark level. Which one you change will depend on which type of subpatch method you are using. If you do not know this then odds are it is the subpatch divisions since that is the default method.
Note increasing these values will slow down modeler as your polycount increases. These values are for display only. Layout will use its own values when rendering.
I hope this helps.

toby
06-15-2009, 01:24 AM
And make sure that Smoothing is on, in the surface editor.

Xcape
06-15-2009, 10:25 AM
Thank you again Silkrooster. It works great with your suggestions.

Xcape

Silkrooster
06-17-2009, 12:29 AM
Your welcome and make sure you take advantage of Toby's answer as well. Smoothing can help it look better without having to increase the subpatch level as high. Smoothing is dependent of surfaces. Therefore if you rename any polygons you will need to have smoothing turned on for those as well.

Xcape
07-03-2009, 12:14 PM
My object looks smooth now but now when I send it over to Layout I get rough edges as how it was back in the perspective.

Can I somehow smooth it out in Layout also?

Thanks

virtualcomposer
07-03-2009, 12:42 PM
try the smoothing button in the surface editor.

Xcape
07-03-2009, 02:38 PM
Thank You.

mike_stening
07-07-2009, 04:59 AM
also check the sub patch level in the object properties as this can be set low so you would see a larger subdivision, ther are 2 settings one for how you see it displayed in layout and one how it will be subdevided for rendering.

DrStrik9
07-07-2009, 11:07 AM
One more thing: after you turn on smoothing in the texture editor, SAVE your object, which will keep the surface attributes with the object file. :-)