PDA

View Full Version : Surface won't glow through glass



sompson
06-07-2009, 01:23 PM
I have a glass bulb object.

I've enabled glow to a surface inside the bulb, but the surface won't glow through glass.

Is there any way to make this work or do I need to use some other technique to make the wire inside the bulb glow?

Any help is appreciated!

Tobian
06-08-2009, 08:33 AM
Glow is not always that useful. Use either Bloom or Corona in the image filter menu. I have noticed that behind glass 'luminosity' doesn't register in the render channels, even though it renders perfectly correctly.

Simply use the brightness of the image it's self to gain the glows. Things that glow should be at least 95-100% bright anyway, and in your case the wire should be especially bright, well above 100% so you can probably set them to over 100% to be sure you don't cause specular highlights to glow too! :D

joelaff
06-10-2009, 09:35 AM
I always do glow effects in the post. In the case of the wire I would render an image ofr just the wire's alpha (or use matte objects, setting the wire to white and everything else to matte black). Then blur that in your compositor and add or screen mode it on top of your rendering.

F_GX
06-11-2009, 04:31 AM
Why is plain luminosity for the wire not sufficient for your problem?

A screenshot would help to understand your project.

Sekhar
06-11-2009, 09:26 AM
This a known issue, the best option IMO is to do it in post as joelaff suggested. See http://www.newtek.com/forums/showthread.php?t=94430 for another discussion on this.