View Full Version : HD Instance ignoring Z Buffer

05-27-2009, 04:17 AM
Hi All,

I'm getting inconsistent use of the Z Buffer on instances (using HD Instance). All the instances were being ignored by the z buffer and so being blurred out to the max by depth of field. I've just taken the scene into the 64bit version of LW to test it out there and it worked fine. I've now brought the 64bit saved scene back into LW 32bit and it seems ot have 'fixed' the issue and all is working fine....anyone had experience of Z Buffer issues with HD Instance? Any solutions or things to avoid/use?


05-27-2009, 04:20 AM
You can monitor the ZBuffer using a simplistic scene (Image Filter / Render Buffer View)

There was a similar bug, ages ago.

05-27-2009, 04:35 AM
yes, I did that a while back when I first came across the issue and it was definitely ignoring the instances in the Z buffer. Just wondering if anyone has found some workaround? Taking the scene into 64bit version and back seems to have worked but it feels a bit like a stickytape and bubblegum solution which doesn't fill me with confidence. If I could make it go from working to not working and back again by changing something in the scene, I'd feel like there was a solid workaround at least. That'd be good.

05-27-2009, 05:04 AM
hmmm.. this might explain why HD instances didnt render when they were nearer to the camera than Sasquatch fur covered objects.
I didnt find a solution (except compositing the fur)

05-27-2009, 01:37 PM
HD instance objects don't show up in any buffers, do they?

For depth, the workaround would be to create a fake z-buffer with black objects and white fog.

05-29-2009, 01:33 PM
HDinstances only show up in the beauty render and z buffer.