PDA

View Full Version : Frame End Beep



IMI
05-23-2009, 08:34 AM
I guess this is just a heads up to NT, if it's even an issue, that is. By that I mean it's not anywhere near important enough to think about for any further LW 9.6 patches, and I don't even know if the Frame End Beep option will be in CORE.

But in Windows 7 (x64), with LW 9.6 (64 bit), the Frame End Beep doesn't beep at all, it just kinda "clunks". Or maybe it's more of a Swish-Thunk-Crackle. Call it what you will. ;)

It sounds like a sound trying to load but not quite making it, like an error.
So I don't know if that's a Windows 7 thing, or what it is, but it's definitely not a "beep", and not anything like the good old frame end beep we've all come to know and love. ;)

As I said, just posting this to make that known, and also to see if anyone can verify that. I really don't think it's a problem with LW, most likely a Windows 7 thing, but I wouldn't exclude the possibility it's on my end only. Clearly it's not something NT should worry about, and I'm not complaining about it, either. :)

I doubt it's my sound card though, as all other sounds on this PC are just fine, including all Windows sounds, music, videos, games and so on. I wouldn't discount the possibility though it has something to do with my EQ and very slight echo I have set in my sound card software.

Speaking of Frame End Beep, is that a file that can be edited somehow? Can it be replaced with some other sound, or is it just embedded deep within the inner guts of the Layout exe itself? Can it be pointed to use some other Windows sound?

evenflcw
05-23-2009, 09:06 AM
I think it uses the so called "PC Speaker/System Speaker". The very simple speaker which beeps during the boot sequence (mainly if there is an error). Perhaps it's requested to beep during n clockcycles, which is why, with todays systems, it no longer sustains itself long enough to sound like a proper beep. Personally, I commonly unplug the cursed thing or turn it off in the os. I just hate that sound, and it's volume can't be regulated. Bios developers that prefer to communicate to users with beeps rather than text on screen are morrons anyway (with one exception).

ramccombe
05-23-2009, 09:27 AM
I'm not sure if this is what your after or if you just want a different sound but you can turn it off in Render Globals.

IMI
05-23-2009, 09:59 AM
So that *is* the POST (Power On Self Test) beep speaker sound that Layout uses? I was wondering about that, but it always seemed so much quieter when Layout did it as opposed to POST time before booting up.
Then again, the POST beep happens long before the operating system loads, so I guess that could have something to do with it, though I can't see how.

My POST beep sounds just fine, the same as it has since I installed this motherboard a few weeks ago. *shrug*

Well, thanks for the info, guys. :)

ramccombe, yeah, I know how to turn it off and I have done that now. I always turned it on or off in the past depending on what I was doing. If I had an image sequence rendering on a different PC which I can't see from this one, while I'm doing something else, I left it on. Too much time goes by with no beep and I know something went wrong without having to get my lazy butt up and go and check it out. ;)
But I always turn it off when I'm sitting here doing test renders. It definitely gets annoying.

Still I'm gonna miss it, and I have to say I'm baffled how it could be messed up if it's coming straight from the mobo. I guess something in Windows 7 is killing the signal along the way, somewhere between when Layout issues the command and the mobo speaker tries to play it.

dwburman
05-23-2009, 01:11 PM
I usually leave it off. Someone did make a plug-in that let you replace the beep with the sound file of your choice but the link is dead. http://flay.com/GetDetail.cfm?ID=2298

Jockomo
05-23-2009, 05:44 PM
Another loose end that would probably take some coder 15 minutes to fix.
People have been asking for this forever.

It would be great if you could set your own audio file for frame end beep.
And it would be even better if they added another feature that let you set and audio file for "Scene end beep" so you'd know when a scene finished.

It'd be nice to set the frame end beep to something subtle like a quiet tick from a clock and then set the scene end for something noisy like an alarm.

rezman
05-23-2009, 07:44 PM
I usually leave it off. Someone did make a plug-in that let you replace the beep with the sound file of your choice but the link is dead. http://flay.com/GetDetail.cfm?ID=2298

http://web.archive.org/web/20070702191534/http://www.binaryartsinc.com/LWave.htm

IMI
05-23-2009, 09:33 PM
http://web.archive.org/web/20070702191534/http://www.binaryartsinc.com/LWave.htm


Thanks for that.
It lists the "replaceBeep" for 64 bit and even has a download LINK (http://web.archive.org/web/20070702191534/http://www.binaryartsinc.com/images/ReplaceBeep_x64.zip), but that leads to a dead end page. Or rather, an archive search page. Every one of those links I tried goes back to the URL you posted above.
I don't know if the 32 bit version can be found or not. Didn't even check, since I don't use 32 bit Layout anymore anyway. Most of my scenes use far more RAM than 32 bit Layout can handle.

But thanks for trying anyway. :)
Now that I know that it exists and what it's called I can search for it, and if I find it I'll post the info here.

BeeVee
05-25-2009, 04:01 PM
You should get the free db&w tools plugin collection. Includes a far more evolved version of the Render beep... ;)

http://www.db-w.com/content/view/124/79/

B