View Full Version : Load Items from Scene

05-19-2009, 07:15 AM
As usual, I don't know what I'm doing. I have never been able to get "load item from scene" to work correctly. When load the first character into the scene using this function, no problem. After that, every character screws up it's and the others bones...like when you turn bones on after forgetting to "rest bones"...but bones rested, on, off ....doesn't make any difference.

To this point, I have been making due by importing rigs to "bare" objects in the scene but as my scenes get more complicated, this is getting old.

I know I must be doing something stupid. (Stupid is as stupid does.) Help please. Thanks.

05-19-2009, 12:41 PM
Maybe a Picture would help withsome help. Note: though the characters look similar they or their rigs are not clones. Thanks for any help.

05-19-2009, 01:51 PM
Load from scene does seem to have gotten a lil bit twitchy, used to work great, but no longer...

Ive found that if u click "select all, select none" back n forth once or twice (then obv uncheck any items ur NOT wanting to import) it works fine.

05-19-2009, 02:20 PM
Sounds like jiggling the handle on the toilet. Was excited for an easy fix, but no dice. Thanks anyway. Other ideas?

05-19-2009, 03:44 PM
Try "Load Elements From Scene"

It won't let you select anything it just loads from a scene (but no lights, cameras, only objects....and rigs, i think?)

Also, if the bones of the character you are loading are named the same as the ones you have in the scene already LW doesn't seem to like it.

05-19-2009, 05:01 PM
The bones were named exactly the same for both objects. (Trying to keep things neat and tidy.) But changing names of all bones didn't help.

I can't find "load elements."

Sorry to bother, still need any help.

Thanks in advance.

05-19-2009, 05:13 PM
bones having the same name wont be an issue... as long as the meshes dont also have the same names... ur sue they're not clones in any way??

05-19-2009, 05:34 PM
The body meshes including teeth and gums are modeled and titled separately. The eyeballs are reused but retitled and resurfaced separately.

This wouldn't have anything to do with the content directory would it? I have always put things in files where I please to keep things organized. I see people mention from time to time that the content directory is very important. But short of having top tell LW occasionally where an object is, I've never had a problem.

05-19-2009, 05:43 PM
Load Elements From Scene is there. If you go to "Edit Menu Layout", look in "File" and it should be there.

05-19-2009, 06:41 PM
Found it...Same result. There most be something screwy I'm doing. or have done with my models. Still open for other ideas.

05-19-2009, 07:48 PM
trash ur configs and start afresh?... maybe just time to post the two scene files/meshes and let others have a crack, see what they get.

05-20-2009, 02:23 AM
Are you using expressions in your scene?

That could be a problem (but can be solved).

Post your scene here if you can (freeze the model or replace it with a Null if needed) so we can really help.

05-20-2009, 06:35 AM
Thanks to you all for your interest. Lino, I created scene with null objects and same rigs...same problem. Attached are the rigged null scenes.

Any help is really appreciated.

05-20-2009, 10:21 AM
No problem here loading the two rigs in the same scene using LIFS.

I'm working in LW9.6. Are you using the same version?

05-20-2009, 11:28 AM
works here too.

05-20-2009, 12:30 PM
9.5. Will try 9.6 later today.

05-20-2009, 12:41 PM

aha... theres your problem right there... 9.5s buggy as hell

05-20-2009, 01:06 PM
Was using 9.5. Downloaded 9.6 and is now working fine! (Didn't have to jiggle the handle, though I'll remember that if I need it.) Happy day! Thank you, thank you! Now I can take "Import Rig" off my hot keys and replace it with "Load Item From Scene."

05-27-2009, 09:12 AM
Load from scene was very screwy in 9.5 - things often leapt all over the place. sometimes saved by saving scene and re-loading. But not often.
Load from scene definitely fails if you try to load multiple versions of the same maestro rig because the expressions pick up the wrong controllers.