PDA

View Full Version : Shading problems



skywalker113
04-03-2009, 04:59 PM
I am creating the inside of a truck. Somthing is not right around the sun blocks, and the console in the middle of them. The areas where there should be shadows are extremly bright. When I apply a bump map to one of the sun blocks, the texture is cut off for some reason.

I have radiosity on and using one spotlight going strait down. I had to crank up all of the textures in the scene over 100 diffuse because the light did not seem to light things up enough.

skywalker113
04-03-2009, 06:32 PM
Ok I solved the problem around that area by turning the spotlight into a area light. But I am still getting some extreme lighting effects. Also, bump maps that are directly below the light do not show. The bump map on the dashboard is applied but is not showing. The only areas that do show a bump map are areas that turn away from the light, like the corners.

skywalker113
04-03-2009, 06:33 PM
heres the picture

skywalker113
04-03-2009, 06:45 PM
Here is a better example. The light is flushing out the bump map.

toby
04-04-2009, 03:51 PM
You shouldn't have to turn the light into a area light just to stop those light-leaks, what are your radiosity settings? You may have to turn up the accuracy. Were you using a low-res shadow map in the spotlight? Turn up the resolution -
As for the last image, the bump is subtle and is being washed out by too-bright light. Same thing will happen in real life. Bump also doesn't show up in radiosity, that will make it less noticeable too.