View Full Version : #include command not working

04-01-2009, 01:38 AM
I did not use Aura for a long while. Yesterday, I use aura George script for some operation and found that #INCLUDE command is not working. Aura just show me a error message indicated the line with #include. All the old scripts with #include command got the same result.

I am using VT[5.2] (Aura-VT 2.7 US).

04-01-2009, 10:27 AM
Hmmm. I just tested the same version, by adding a print statement to one of the default includes. It worked ok. I'm not sure what to attribute your problem to. The exact placement of an include call can be fussy, but I don't know why you'd be getting an error for a script that has previously worked.

Have you tried invoking the include with an explicit path?

04-01-2009, 10:46 AM
Yes. I test it with full path name. Still get the same error message. If your system is fine with "include" command, then it might be my VT system problem. It have been added with so many things since I have to test anythng for my clients.
I might try reinstall my VT[5.2] but it will not happen in this week. :D
Thank you for the reply.

04-01-2009, 10:47 AM
You're very welcome, Chen. I'm happy to be able to do something for a person who has been such a big help to many here.

10-12-2009, 07:24 AM
I have had the same problem as I load a script in George - Bin menu.
No script in the George - All menu works.

But as I load a standart script, for exampel Center in the Bin menu,
it works without error and in All menu again too.


10-12-2009, 09:49 AM
I wonder ... are you by any chance running Vista, or Win7?

10-19-2009, 11:49 PM
I have reinstall my VT4 and VT5 and now both version of AuraVT run without problem.
I still not sure what cause "#include" command failed but I suspect that the (#include) search path of Aura have been miss placed to some where.

10-20-2009, 05:15 AM
Include statements often refer to relative paths. This can fail if defaults.grg is missing or messed up.

The reason I asked about Vista is because, as you may know, it interferes with attempts to manually write files to Program Files(x86). Weird things can happen if you edit scripts at all (a proxy file is written somewhere else on the system, and pretends to be in the correct location.