View Full Version : F9 key that works for a mac?

03-26-2009, 09:10 PM
Is there a way to re-assign this for us mac guys without re-setting up quick keys for MAC in general?

03-26-2009, 09:12 PM
doesn't command-F9 work for you in Lightwave?

03-26-2009, 09:16 PM
ah..got it...didn't find it in the forum, but saw it on the v.9 spec sheet.

Good 'ol comand+R and Command+Shift+R

Scazzino, f9 is expose, you could remap, simpler to just do what they did..and better. Thnx guys.

03-26-2009, 09:59 PM

It's a funny story. Not ha ha funny, but that other kind.

Just before I came here, F9 wasn't used anywhere in the OS, so LW Mac users had it easy.

Then I think it was Tiger that came out, and Apple mapped Exposť to F9.

When LW9.0 shipped, it wasn't a huge problem, because most of our users used the command+F9 trick to get around the default mapping for F9. But I'm not sure anyone on the LW team knew our users were doing this. I sure didn't. Our instructions at the time said to just remap Exposť.

But then, Apple changed the mapping on the PowerBooks (I forget which ones) so that F9 turned into Function+F9 (the Fn key was only found on the PowerBooks at the time).

In the meantime, we found a (the) bug in the event processing bug that would let command key combos skip by the MacOS event system. So we ... fixed ... it, by using a more modern event processing system.

And in that next Open Beta release, we had a sudden flurry of users mad that Command+F9 no longer worked.

So we 'unfixed' it, actually adding a special case for the command+function keys.

And THEN, Apple changed their MacBook keyboards to double up the features on the F9 key. So even Fn+F9 wouldn't work. Then they released some new version of the MacBook or MBP keyboard overseas, which killed Cmd+Fn+F9.

Currently, I believe Command+Shift+Fn+F9 is what you have to use on those systems.

So we said, screw it, Command+R it is.


03-26-2009, 10:16 PM
Scazzino, f9 is expose, you could remap, simpler to just do what they did..and better. Thnx guys.

Yes, I know... I've just been using command-F9 ever since LW7 I think... still works in 9.6 for me... never remapped anything... Expose still uses F9... command-R works too now... but I'm not on a PowerBook... is that the problem?


03-26-2009, 11:14 PM
That is funny, but not ha ha like you said. I haven't used LW on a Mac in some time, but I always said screw it to Expose and the OS when my applications were involved. I actually got mad at the OS for getting in the way of my production. Kinda like, "This button is mine, how dare you override it?" :D

03-28-2009, 01:46 AM
I never knew about the cmd-f9 thing. I always just remapped all the OS (exposť) function keys to use cmd-shift-function key. The OS defaults get in the way of Final Cut Pro's keyboard shortcuts for edits as well as Lightwave's keyboard commands.

04-06-2009, 08:09 AM
i just Unmapped expose, and put whatever functionality i wanted on the hot spots in the corners of the screen.

then I got this fancy aluminum keyboard, and it had audio buttons mapped to my F keys! me likes audio buttons.

so this time, the special features are only avail if you hit the fn key first. I can live w/ that. I can't live w/out my f9 key in LW.

04-06-2009, 08:52 AM
Yeah, I too remapped my expose keys. I just use F9 for LW render now. I didn't really use the F9 expose function really anyway.

04-06-2009, 09:03 AM
Straight ole' F9 works for me. Just turned off Expose, I never use it anyways. :)

I think someone at apple is playing games with you Chilton. "Watch we'll get this guy mwhahAHAHAHahaha... " Or something to that effect.

04-06-2009, 10:40 AM
If you ever use Final Cut Pro or LW, you really need to disable Expose. Besides, what does it really do anyway?

04-06-2009, 07:55 PM
I use Expose's F8 (with spaces), F9, F10 & F11 all the time. LW's same keys work as-is with the command key. In Lightwave I just press Command-F9, Command-F10, Command-F11, etc. Works fine here...


04-07-2009, 01:39 AM
I use Exposť a lot, use hot corners only is always my solution to keep F9. : )

Nick Hilligoss
04-28-2009, 01:18 AM
I'm glad to find this thread - just discovered F9 doesn't work on my new Mac Pro OS X Leopard, tried everything with no luck.
Command -R works!
Command-F9, Shift-F9, Control F9 do nothing.
Command-Shift-fn-F9 do something weird to the display, get double images of objects, but no render. pressing fn-F9 slightly shrinks the whole window, pressing it again changes it back.
So Command-R will do until I can work out how to restore F9. Thanks guys!
What is Expose, anyway? I very much doubt I will ever want it. How do you disable it? I'm a bit of a newbie on a Mac.

04-28-2009, 10:29 PM
I just remap the key in lightwave..i make '9' to act as f9