View Full Version : Bone twist problems

03-22-2009, 02:19 AM
I suspect that this is a no-no, but I'd like to know how to recover from it if/when it happens again.
I was carefully rigging a figure's legs for the umpteenth time and after I got everything the way I wanted it I mirrored the hierarchy from the left side to the right.
The hierarchy started with a bone I called RT_Pelvis. So I got everything mirrored and then bone-twisted each side to get the rotations all right and lined up. Then I rested them all to test them out.

Well everything worked great for the legs, but I decided I didn't like the rotations of the the mirrored pelvis bones, the RT_Pelvis and the LT_Pelvis.
I did this testing on frame 10 and afterwards deleted the keys for each bone at that frame, to get things back to normal. I then moved the slider and all the bones were in fact back to normal.

So (at frame 0 again) I deactivated the bones for each hierarchy, and made the necessary bone twists on the pelvis bones. Then when I reactivated/rested all the bones again, the mesh just went nuts, squashed all in on itself. No, I didn't use scale or rotate or anything on any of them. I know about that. ;)
I just used bone twist on the two pelvis bones, and then record rotation for each.

Now, this has happened before to me. It seems I keep breaking some important law of rigging somewhere. I guess once you've rested your bones, you can no longer make changes to the rotation even if you do so with the bones deactivated?

Is there a way to get out of that problem once it's happened? There's no undo for bone twist, it seems, which is really really f... well, never mind...

I already deleted all the leg bones and am starting over, but as I said, this sort of thing has happened a few times already, and I'd like to know if there's anything I can do to get my mesh back to normal after it happens, rather than to just start all over again.

Also, unrelated but rather than starting a new thread, in this figure I have three spine bones which refuse to select along with all the other bones. I can select every bone in the figure with middle mouse marquee select, but those three *never* get selected along with the rest. I can select them each manually, or shift-select them all, but no way, no how can I select them with all the others at once. Anyone know what's up with that? They're not locked, either.

Thanks. :)

03-22-2009, 08:35 AM

I can't say for sure without seeing the rig, but you might try exporting the rig and reimporting it (Setup—Edit—Export Rig). That has often cleared up a lot of similar problems for me.

If I understand the question correctly, you should be able to change the rotation of a rested bone—as long as you rest it again after you've rotated it.

As far as general bone tool problems, accommodating the quirks of Bone Twist unfortunately seems to be part of the learning process. I know I've had a lot of unpleasant, frustrating moments over the last few years similar to what you describe. Sorry. If I were there looking over your shoulder, I might be able to be more helpful.

If you don't already have them, Jonny Gorden's Lightwave Cartoon Character Creation (Vol.'s 1 and 2) books are enormously helpful in getting up to speed on basic bone skills. You should be able to pick the books up fairly cheap on Amazon.

03-22-2009, 08:37 AM
I do this sort of thing all the time with no ill effects.
Did you try reresting the whole rig after using bone twist?
Ive also had the selection thing come up once in awhile.

03-22-2009, 02:01 PM
Thanks guys. :)

I guess this was what was causing the problem - I discovered I somehow had three identical hip bones on each side directly on top of each other, where they looked like only one. I assume that came from mirroring the hierarchy at some point - as I said, I kept having to redo the legs.
I think one or two of those duplicates weren't getting deactivated along with the others and causing the mesh problem.
Getting rid of the duplicates seems to have solved all my leg weirdness though.

03-23-2009, 03:27 AM

I tried as you suggested and exported my rig and re-imported it and my bone twist problems went away and I can also now select those spine bones I couldn't select before, with the whole group at once.
Go figure.
Thanks allot for that suggestion! :) -- I have a feeling I'll be using that idea allot in the future.
PS - I love your illustrations at your website - very cool stuff there!


It turned out it wasn't just those extra bones. It seemed to have worked at first, but later I decided to twist a few others and had similar problems. I don't know anywhere near enough about it to properly troubleshoot the issue, but it seems exporting the rig and re-importing it "fixes" whatever the deal is.
I don't know if I can blame LW or not. I'd say chances are pretty good I've done something wrong along the way, created some sort of instability, but hell if I can find it. However, the rig seems to be cooperating well enough now, and the export/import rig thing seems to clear up the problems. I wish I knew more about it to be able to find out what went wrong though.

Overall, this, my first major attempt at a full character rig isn't going too badly. Although the figure object does have a few weight maps, I'm not having to use any, which amazes me. I have some issues in the elbows and knees I'm trying to work out, but that will come eventually. Otherwise, the deformations aren't too bad. Pretty much everything I've been able to achieve has come from watching your videos at Vfx Cast, so I'm looking forward to getting a couple of your more recent videos - maybe then I can do this and say I actually know what I'm doing. ;)

Another thing I was wondering about - I created some target nulls for the eyes to track and each eye has a dotted line drawn to its associated target. In the properties, I see the "draw line to" thing is set to "none", but the lines stay there and visible. Is there a way to get rid of those or to make them invisible?

Thanks again. :)