PDA

View Full Version : Bone Motion Option Rotation Item OFF by 10 degrees



hdace
03-21-2009, 10:42 AM
I'm talking about an ankle bone here. I create a null, parent it to the ankle. Then I zero all paramaters and unparent it. So it now has an identical orientation to the ankle except that it has world coordinates.

With me so far?

Now I go to the ankle motion options, "controllers & limits" tab, "rotation" tab, click the "Rotation Item" menu and select the null. Click World. Select "Same as Item" on all the controller menus. THE BONE SHOULD NOT MOVE. But it does. On the test that I have been creating and recreating for a day and a half now always gives me the same results. Heading becomes 3.37. Pitch: 9.82, Bank: -1.06.

Obviously I could use Match Goal Orientation but you can't envelope that. BTW, MGO does work correctly while Rotation Item doesn't.

Someone fix this!!! Tell me I'm bonkers. Anything!

hdace
03-21-2009, 11:33 AM
Okay I finally thought of something new. I've been recording the pivot rotation first. It did not occur to me that this would cause a problem but it does and so I guess I was bonkers after all!

I have always found it much easier to deal with bones if I automatically, almost without thinking, record the pivot rotation immediately upon importing an object with bones, so I left that stage out of my previous post. I still don't understand why it should be an issue since Match Goal Orientation still works. I hope this gets fixed eventually.

Does Fog Bugz still work when we're out of Beta? Would this be a bug or a feature request? My opinion is that it's a bug.

Castius
03-22-2009, 01:55 AM
Yup record pivot will do it. I'd still send this to Newtek. It always help them fix these issues.

hdace
03-24-2009, 05:54 PM
your case's tracking ticket: 21675_l1g1kocu

Giacomo99
03-24-2009, 10:20 PM
I'm late to this thread, but here's my two cents: Record Pivot Rotation isn't as reliable as it should be. Over time I've gotten in the habit of simply exporting the rig periodically and then re-importing it to a clean version of the model. This has solved SO many problems I can't even begin to list them.

hdace
03-25-2009, 04:19 AM
I tried that once and it just crashed Layout. But that was during beta and it does sound very intriguing so I'll give it another go! Thanks for the tip.

RebelHill
03-25-2009, 06:20 AM
ive never had a problem with rpr... i always use it, keeps everything at 0,0,0 when in rest... did u try doing rpr on the null as well as the bone though, that should sort your issue out. also, theres a match goal plugin, that outputs values so u can envelope it, u could use an offset bone with constraint to get an envelopable match goal, or u can use IK to provide the same funtions as match goal. see the foot in the rig in my sig.

Castius
03-25-2009, 01:41 PM
I think what hdace is trying need to be fixed. One it should be fixed by Newtek. I'm glad to see he put in a bug report. Record Pivot Shouldn't cause so many problems.

Second i also think it's a bad workflow. I think record pivot rotation should be use very minimal. I remember useing it a lot when i started rigging in LW. As well as in other programs. I have found that workflow is not one i recommend to people. Working with offsets offers so much more advantages to record pivot. So now there is only a few times i would recommend it.

In terms of Match goal. I think it's just as flawed as record pivot. Match goal does things outside the normal motion system. Making it hazardous to many situations. I would do everything to avoid it if i was building a rig.