View Full Version : RPF Export

02-18-2009, 07:48 AM
when I render out rpf files through image processing/rpf export and extract the depth information in After Effects, I get an image that doesn`t look correct. I tried the same thing with an rpf file that came with a tutorial and had no problem in After effects. So something goes wrong in Lightwave.

(LW 9.6 on a Mac Pro)

Can anybody help, please?


02-18-2009, 11:37 AM
I had a very similar albeit more colorful result when trying to do the same thing but extract a normal buffer rather than depth.

maybe this is a broken plugin on mac?

02-19-2009, 01:42 AM
It would be great if someone could confirm that rpf export on the mac does or doesn`t work.
If it works:
- how does it work?

If it doesn´t work:
- is there are workaround?
- why didn`t that get fixed?

02-22-2009, 01:14 AM

I had the same problems a week or so ago when rendering out an RLA or an RPF file from LW. I was trying to extract depth info in AE and when I'd click on different points I'd get results like 0, plus infinity, minus infinity, infinity, 15,600, etc.

This didn't work for a very long time, and then it sort of worked in LW 8 I think and early LW 9 (at least the object ID worked). In Release Candidate 12 (Mac 32) I can only get the material ID to work in the RPF.

Shawn Marshall
Marshall Arts Motion Graphics

02-25-2009, 08:03 AM
I have been trying to do DOF Blur in AE using the RLA and RPF export with no success as well, anyone using a working alternative?

02-25-2009, 01:05 PM

I've been playing around with the Buffer Export (Depth) in the Image processing tab. You can render out a sequence of greyscale depth buffer images along with your full color sequence. Bring both into your AE comp and apply Compound blur to your color sequence using the depth buffer sequence as the blur layer.

In the tests I've done I find it works better to precompose the depth buffer sequence and blur it a bit; the edges aren't antialised. You can also use levels to adjust the degree of blur. Unfortunately, you have no control over the depth range in LW.

Shawn Marshall
Marshall Arts Motion Graphics

And remember, no matter where you go, there you are...

02-28-2009, 02:48 PM
And remember, no matter where you go, there you are...


05-09-2009, 07:18 PM
In 9.1 I had beautiful depth channels for use with the After Effects depth of field filter.

Starting in 9.3 it was garbled, not working. I received an email from LW that the new 9.6 would fix it, but it did not.

I'm at wits end. The compound blur option just doesn't have adequate quality for what I'm doing. I did find that saving out the depth channel in the export .psd option works great, but I can't figure out a way to get After Effects to recognize the channel, which is output as a separate layer, as a depth layer.

Please help!

05-11-2009, 07:17 AM
As there's a hot fix for 9.6 coming out soon, now would be the time to report the bug again - and any reproducible bug.

Hopefully, they'll give a report on what's fixed, what's not with the hot fix?


10-15-2009, 12:46 PM
Unfortunately, you have no control over the depth range in LW.

Z Range was added in 9.6. it's on the Render Globals panel.

10-15-2009, 07:10 PM
I played around with the Z-range feature. Unfortunately, I can find no documentation on how it's supposed to work. It defaults to a range of 0 to 1,000,000. 0 to 1,000,000 what? Miles? Millimeters? Light years?

And the RPF depth export is still broken, which is one of the many reasons I've purchased Cinema 4D Studio. I'm really tired of stuff working and breaking and working and breaking.

Shawn Marshall
Marshall Arts Motion Graphics

10-15-2009, 07:25 PM
I'm also interested in export to After Effects.

This link might be useful? I'd be very interested in whether this is a workable solution.