PDA

View Full Version : Unbearably Slooowww!!!



HotShoe
02-08-2009, 05:01 PM
Sorry for such a bummer first post but I don't know where else to turn.

I'm a LW rookie and I am trying to learn the program. I have the entire set of Kurv dvd's and I am picking things up nicely. My only problem is for some reason LW is running so slow on my Mac I can't even move around an object in the viewports without an unbearable delay. It's so bad I've given up trying to use it. I thought the update would solve my problem but it's been bogged down since 7.5.

I just downloaded the new 9.6 update for PPC macs. I'm running LW on a dual 800 G5 with 8 gigs of ram. My system handles every app just fine but for some reason I can't use LW. I've tried a complete system reinstall to no avail. At this point I wonder if it's my video card and 30" cinema display slowing things down? I have no idea what it could be.

I even purchased a car model from 3d02 to see if it would work and it was worse. The model has @470,000 polygons and just one layer. I merge points but it did nothing. I can't even zoom in or out of a single viewport without waiting an eternity.

Does anyone have any idea what could be wrong? I've struck out everywhere and this is my last chance. I'm waiting to buy a new Mac Pro when they come out but I'm afraid I've sen soooo many posts saying LW doesn't work on Macs well I'm almost afraid to.

I just think I'm doing some dumb rookie mistake no one has caught. i refuse to believe the app runs like this on all Macs. If it did Newtek would never sell any copies.

Help!!!! Please!

Chilton
02-08-2009, 05:12 PM
Hi,

Try the Universal Binary. The PPC version is only for backwards compatibility with plug-ins that haven't made the transition to Universal Binary status yet. The UB of 9.6 should be much better.

Thanks,
-Chilton

(We use PPC G5s here as well, and it shouldn't have a problem with those files)

rakker16mm
02-08-2009, 05:15 PM
Sorry for such a bummer first post but I don't know where else to turn.

I'm a LW rookie and I am trying to learn the program. I have the entire set of Kurv dvd's and I am picking things up nicely. My only problem is for some reason LW is running so slow on my Mac I can't even move around an object in the viewports without an unbearable delay. It's so bad I've given up trying to use it. I thought the update would solve my problem but it's been bogged down since 7.5.

I just downloaded the new 9.6 update for PPC macs. I'm running LW on a dual 800 G5 with 8 gigs of ram. My system handles every app just fine but for some reason I can't use LW. I've tried a complete system reinstall to no avail. At this point I wonder if it's my video card and 30" cinema display slowing things down? I have no idea what it could be.

I even purchased a car model from 3d02 to see if it would work and it was worse. The model has @470,000 polygons and just one layer. I merge points but it did nothing. I can't even zoom in or out of a single viewport without waiting an eternity.

Does anyone have any idea what could be wrong? I've struck out everywhere and this is my last chance. I'm waiting to buy a new Mac Pro when they come out but I'm afraid I've sen soooo many posts saying LW doesn't work on Macs well I'm almost afraid to.

I just think I'm doing some dumb rookie mistake no one has caught. i refuse to believe the app runs like this on all Macs. If it did Newtek would never sell any copies.

Help!!!! Please!

470,000 polygons might be a tad on the large side. Try loading some simpler models to see if things work a little faster. That will tell you whether you have an issue with the software or the model. I would also recommend trying the UB version.

What Chilton Said

HotShoe
02-08-2009, 05:24 PM
Wow! You guys are fast around here. I'm impressed.

I will try the UB tomorrow when I get in to the studio. Thanks again for such quick responses. :thumbsup:

HotShoe
02-08-2009, 05:50 PM
Just thought of another stupid question related to this problem...

If I have an object with 470,000 polygons does it effect performance at all if I use the size tool and scale it down? Or is it still just related to total polys?

lwanmtr
02-08-2009, 05:53 PM
Its all based on points/polys, so sizing doesnt really effect it.

HotShoe
02-09-2009, 05:15 PM
Well, installed the UB today from scratch and it definitely help some. Still bogs down pretty bad but it's at least manageable.

Funny thing is now when I try to center and ground my model it locks up and I get the spinning beach ball of eternity. I have a bunch of import/file questions but I'll try ask those in the appropriate section.

Thanks again to those who helped!

lwanmtr
02-09-2009, 05:18 PM
You might start by either renaming or deleting the config files (users-preferences-lightwave3d) and put a folder in the same folder where the Lightwave apps are. You might have config issues

Scazzino
02-09-2009, 08:42 PM
Also make sure your not using GLSLShaders in the OpenGL settings... that's been known to gag things before... If it's set to GLSLShaders, try changing it to MultitextureShaders instead...

rakker16mm
02-09-2009, 08:58 PM
Also make sure your not using GLSLShaders in the OpenGL settings... that's been known to gag things before... If it's set to GLSLShaders, try changing it to MultitextureShaders instead...

Thank you for that. I might need to check that on my machine.

Scazzino
02-09-2009, 09:07 PM
Thank you for that. I might need to check that on my machine.

No problem, GLSL has been known to really gag things on some video cards... particularly on my older G5 with the ATI-Radeon 9800 Pro...

rakker16mm
02-09-2009, 09:47 PM
No problem, GLSL has been known to really gag things on some video cards... particularly on my older G5 with the ATI-Radeon 9800 Pro...

Well I just checked my open Gl settings and sadly this is not the cause of the frequent visitations by the spinning beach ball of death. My G5 has GeForce 6600. I don't really know if that is better or worse, but it runs two monitors OK most of the time. That might be slowing things down a bit, but I just can't work efficiently with only one.

Chilton
02-09-2009, 10:41 PM
Hi,

To get the best performance in Layout, set your viewports to use the Texture Shaded Solid. That, combined with the VBO support in Layout, should yield some pretty rapid speeds. It should be faster than almost any of the other settings, especially with higher polygon scenes. The memory buffer on the video card might become a bottleneck though.

-Chilton

avkills
02-10-2009, 04:00 AM
Could it be a bounding box threshold problem also?

Is that GeForce 6600 an Apple supplied card?

Dual 800 G5? Do you mean a Dual 1.8 Ghz? If your processors are 800 Mhz then it probably isn't a G5.

-mark

HotShoe
02-10-2009, 07:34 AM
Ooops! Nice catch on the typo. I have a dual 2.5 ghz powerpc G5.

I'll check those other settings but it's all starting to sound like another language to me! ;) This reminds me of looooong ago when I started learning PS!!!!

toby
02-13-2009, 03:43 PM
I think he's having slowness with translating geometry in modeler. This is much slower than translating an object in Layout - note that there is no translating of objects in modeler, only the geometry of objects. For a car, you'd want all the wheels to stay at 0,0,0 and the car body's center of gravity to be at 0,0,0 - then position everything in Layout.

This is true with other programs too, if you're changing the value of every point in a model it will take longer than just changing the value of the object. And Max or Maya, you wouldn't go into polygon/face mode to move a wheel into place or set the car on the ground.

The fastest modes in Modeler are wireframe, smooth shade, and texture.

rsfd
02-14-2009, 07:30 AM
@ HotShoe
I remember these problems by myself. Always blamed my old 2x1.8 G5 and the weak ATI graphic card for that and finally even switched to another (more "modern") application, that could handle large models @1.800,000 polys quite well on that same machine, but I always stealed a glance at LW for its better capabilities.
Since LW OB UB 9.5/9.6 I don't have any problems any more, even the G5 handles models with ~2Mio polys.

So, I'm with lwanmtr, I also think it's a configuration/installation issue or conflict.
Try to delete all prefs, maybe all LW and perform a clean, new install of UB 9.6.
And have a look at Chiltons post (#13) and tobys (#16) for best viewport settings.
In Modeler, my G5 (and my MacPro) made a performance boost after turning off "Transparency Channel" in OpenGL Display Options.

[edit]
you might want to read the new Install Guide ( found here: http://www.newtek.com/forums/showthread.php?t=94245 ), so see which pref files can go where.